HDU 5317 RGCDQ

 
Time Limit: 3000MS Memory Limit: 65536KB 64bit IO Format: %I64d & %I64u

 Status

Description

Mr. Hdu is interested in Greatest Common Divisor (GCD). He wants to find more and more interesting things about GCD. Today He comes up with Range Greatest Common Divisor Query (RGCDQ). What’s RGCDQ? Please let me explain it to you gradually. For a positive integer x, F(x) indicates the number of kind of prime factor of x. For example F(2)=1. F(10)=2, because 10=2*5. F(12)=2, because 12=2*2*3, there are two kinds of prime factor. For each query, we will get an interval [L, R], Hdu wants to know  \max GCD(F(i),F(j)) (L\leq i<j\leq R)
 

Input

There are multiple queries. In the first line of the input file there is an integer T indicates the number of queries. 
In the next T lines, each line contains L, R which is mentioned above. 

All input items are integers. 
1<= T <= 1000000 
2<=L < R<=1000000 
 

Output

For each query,output the answer in a single line. 
See the sample for more details. 
 

Sample Input

2 2 3 3 5
 

Sample Output

1 1
 

Source

2015 Multi-University Training Contest 3

 

题意

定义函数f(x)表示:x的不同素因子个数。

给定L和R(L<=i< j<=R),求区间内任意不相等的两个数f(x)的最大公约数的最大值。

解法

2*3*5*7*11*13*17 > 10 ^ 6 ,所以f(x)的最大值为7.

先用筛素数的方法求出每个数素因子的个数,然后记录一下每个数i是否有j个素因子(f[i][j])再求出其前缀和就是2到i中素因子个数为j的数的个数。

对于每次查询[l, r],如果存在j对任意k(j < k)有sum[l-1][j] - sum[r][j] > 1并且sum[l-1][k] - sum[r][k] <= 1, 那么说明存在 l <= x < y <=r 使 gcd(f(x),f(y)) = f(x) = f(y) 即此时的f(x)为答案。

#include <iostream>
#include <stdio.h>
using namespace std;
const int maxn=1000005;
int a[maxn]={0};
int sum[maxn][8];
void get()
{
    int i,j;
    for(i=2;i<=maxn;i++)
    {
        if(!a[i])
        {
            for(j=i;j<=maxn;j+=i)
            a[j]++;
        }
    }
    for(i=2;i<=maxn;i++)
    for(j=1;j<=7;j++)
    sum[i][j]=sum[i-1][j]+(a[i]==j);
}
int main()
{
    get();
    int T;
    scanf("%d",&T);
    while(T--){
        int l, r;
        scanf("%d%d",&l,&r);
        int ans = 1;
        for(int i = 7; i > 0; i--)
        {
            if(sum[r][i] - sum[l-1][i] > 1){
                ans = i;
                break;
            }
        }
        printf("%d\n",ans);
    }
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值