HDU5001 Walk(概率DP)

A - Walk
Time Limit:15000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u
Submit  Status  Practice  HDU 5001

Description

I used to think I could be anything, but now I know that I couldn't do anything. So I started traveling. 

The nation looks like a connected bidirectional graph, and I am randomly walking on it. It means when I am at node i, I will travel to an adjacent node with the same probability in the next step. I will pick up the start node randomly (each node in the graph has the same probability.), and travel for d steps, noting that I may go through some nodes multiple times. 

If I miss some sights at a node, it will make me unhappy. So I wonder for each node, what is the probability that my path doesn't contain it.
 

Input

The first line contains an integer T, denoting the number of the test cases. 

For each test case, the first line contains 3 integers n, m and d, denoting the number of vertices, the number of edges and the number of steps respectively. Then m lines follows, each containing two integers a and b, denoting there is an edge between node a and node b. 

T<=20, n<=50, n-1<=m<=n*(n-1)/2, 1<=d<=10000. There is no self-loops or multiple edges in the graph, and the graph is connected. The nodes are indexed from 1.
 

Output

For each test cases, output n lines, the i-th line containing the desired probability for the i-th node. 

Your answer will be accepted if its absolute error doesn't exceed 1e-5.
 

Sample Input

2 5 10 100 1 2 2 3 3 4 4 5 1 5 2 4 3 5 2 5 1 4 1 3 10 10 10 1 2 2 3 3 4 4 5 5 6 6 7 7 8 8 9 9 10 4 9
 

Sample Output

0.0000000000 0.0000000000 0.0000000000 0.0000000000 0.0000000000 0.6993317967 0.5864284952 0.4440860821 0.2275896991 0.4294074591 0.4851048742 0.4896018842 0.4525044250 0.3406567483 0.6421630037
//给一个无向图 , n个节点,m条边
//每个节点为起点的概率相同 
//问每个节点走d步后不经过这个节点的概率
//不经过这个节点的概率等于去掉该节点的图中走了d步到其他节点的和
//dp[i][j] 为走了i步到达j个节点的概率
//dp[i][j] = segma(dp[i-1][v])/vec[j].size()
#include<cstdio>
#include<cstring>
#include<iostream>
#include<vector>
using namespace std ;
const int maxm = 10010 ;
const int maxn = 60 ;
double dp[maxm][maxn] ;
double outdegree[maxn] ;
double p[maxn] ;
vector<int>vec[maxn] ;
int main()
{
   // freopen("in.txt" ,"r" , stdin) ;
    int T ;
    int m , n, d ;
    scanf("%d" ,&T) ;
    while(T--)
    {
        scanf("%d%d%d" ,&n , &m , &d) ;
        memset(p , 0 , sizeof(p)) ;
        for(int i = 1;i <= n;i++)
        vec[i].clear() ;
        for(int i = 1;i <= m;i++)
        {
            int a , b ;
            scanf("%d%d" ,&a ,&b) ;
            vec[a].push_back(b) ;
            vec[b].push_back(a) ;
        }
        for(int s = 1;s <= n;s++)
        {
            memset(dp , 0 , sizeof(dp)) ;
            for(int i = 1;i <= n;i++)
            dp[0][i] = 1.0/(double)n ;
            double ans = 0 ;
            for(int i = 1;i <= d;i++)
            for(int j = 1;j <= n;j++)
            {
                if(j == s)continue ;
                for(int k = 0;k < vec[j].size() ;k++)
                {
                    int v = vec[j][k] ;
                    if(v == s)continue ;
                    dp[i][j] += dp[i-1][v]/(double)vec[j].size();
                }
            }
            dp[0][s] = 1.0/(double)n ;
            for(int j = 1;j <= n;j++)
            p[s] += dp[d][j] ;
        }
        for(int i = 1;i <= n;i++)
        printf("%lf\n" , p[i]) ;
    }
    return 0 ;
}

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值