HDU 3853 LOOP (概率DP求期望)

D - LOOPS
Time Limit:5000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u
Submit  Status

Description

Akemi Homura is a Mahou Shoujo (Puella Magi/Magical Girl). 

Homura wants to help her friend Madoka save the world. But because of the plot of the Boss Incubator, she is trapped in a labyrinth called LOOPS. 

The planform of the LOOPS is a rectangle of R*C grids. There is a portal in each grid except the exit grid. It costs Homura 2 magic power to use a portal once. The portal in a grid G(r, c) will send Homura to the grid below G (grid(r+1, c)), the grid on the right of G (grid(r, c+1)), or even G itself at respective probability (How evil the Boss Incubator is)! 
At the beginning Homura is in the top left corner of the LOOPS ((1, 1)), and the exit of the labyrinth is in the bottom right corner ((R, C)). Given the probability of transmissions of each portal, your task is help poor Homura calculate the EXPECT magic power she need to escape from the LOOPS. 




 

Input

The first line contains two integers R and C (2 <= R, C <= 1000). 

The following R lines, each contains C*3 real numbers, at 2 decimal places. Every three numbers make a group. The first, second and third number of the cth group of line r represent the probability of transportation to grid (r, c), grid (r, c+1), grid (r+1, c) of the portal in grid (r, c) respectively. Two groups of numbers are separated by 4 spaces. 

It is ensured that the sum of three numbers in each group is 1, and the second numbers of the rightmost groups are 0 (as there are no grids on the right of them) while the third numbers of the downmost groups are 0 (as there are no grids below them). 

You may ignore the last three numbers of the input data. They are printed just for looking neat. 

The answer is ensured no greater than 1000000. 

Terminal at EOF 


 

Output

A real number at 3 decimal places (round to), representing the expect magic power Homura need to escape from the LOOPS. 

 

Sample Input

2 2 0.00 0.50 0.50 0.50 0.00 0.50 0.50 0.50 0.00 1.00 0.00 0.00
 

Sample Output

6.000
和上一篇博客POJ 2096是一个意思。
 

题意:
有一个迷宫r行c列,开始点在[1,1]现在要走到[r,c]
对于在点[x,y]可以打开一扇门走到[x,y]或者[x+1,y]或者[x,y+1]
消耗2点魔力 问平均消耗多少魔力能走到[r,c]

分析:

输入r和c 随后r行c列 输入三个概率
假设dp[i][j]表示在点[i,j]到达[r,c]所需要消耗的平均魔力(期望)
则从dp[i][j]可以到达:
dp[i][j],dp[i+1,j],dp[i][j+1];
对应概率分别为: p1[i][j],p2[i][j],p3 [i][j]
由E(aA+bB+cC...)=aEA+bEB+cEC+...//包含状态A,B,C的期望可以分解子期望求解
得到dp[i][j]=p1[i][j]*dp[i][j]+p2[i][j]*dp[i+1][j]+p3[i][j]*dp[i][j+1]+2;

得出最终公式:dp[i][j]]=(p2[i][j]*dp[i+1][j]+p3[i][j]*dp[i][j+1]+2)/(1-p1[i][j])

注意分母为0的时候要特判一下

以dp[r][c]=0为起点进行逆向递归即可

#include <iostream>
#include <stdio.h>
#include <string.h>
using namespace std;
double f[1005][1005];
double p1[1005][1005],p2[1005][1005],p3[1005][1005];
int main()
{
    int n,s;
    while(scanf("%d%d",&n,&s)!=EOF)
    {
        for(int i=1;i<=n;i++)
            for(int j=1;j<=s;j++)
        scanf("%lf%lf%lf",&p1[i][j],&p2[i][j],&p3[i][j]);
        memset(f,0,sizeof(f));
        for(int i=n;i>=1;i--)
        {
            for(int j=s;j>=1;j--)
            {
                if(i==n&&j==s)
                    continue;
                if(p1[i][j]==1.00)
                    continue;
                f[i][j]=p2[i][j]*f[i][j+1]+p3[i][j]*f[i+1][j]+2.0;
                f[i][j]/=(1-p1[i][j]);
            }
        }
        printf("%.3f\n",f[1][1]);
    }
    return 0;
}

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值