UVA - 575 Skew Binary

UVA - 575 Skew Binary

题目大意: 按照题目要求输出即可

Sample Input

10120
200000000000000000000000000000
10
1000000000000000000000000000000
11
100
11111000001110000101101102000
0

Sample Output

44
2147483646
3
2147483647
4
7
1041110737

解题思路:

#include <iostream>
#include <cmath>
#include <cstring>
#include <cstdio>
using namespace std;

int main() {
    char s[100];
    int sum;
    while (scanf("%s",s) != EOF && strcmp(s,"0") != 0) {
        int l = strlen(s);
        sum = 0;
        for (int i = 0; i < l; i++) {
            sum = sum + (s[i] - '0') * (pow (2, l - i) - 1);
        }
        printf("%d\n",sum);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值