1106 Lowest Price in Supply Chain (25分)

23 篇文章 0 订阅

1 题目

1106 Lowest Price in Supply Chain (25分)
A supply chain is a network of retailers(零售商), distributors(经销商), and suppliers(供应商)-- everyone involved in moving a product from supplier to customer.

Starting from one root supplier, everyone on the chain buys products from one’s supplier in a price P and sell or distribute them in a price that is r% higher than P. Only the retailers will face the customers. It is assumed that each member in the supply chain has exactly one supplier except the root supplier, and there is no supply cycle.

Now given a supply chain, you are supposed to tell the lowest price a customer can expect from some retailers.

Input Specification:
Each input file contains one test case. For each case, The first line contains three positive numbers: N (≤10^​5​​), the total number of the members in the supply chain (and hence their ID’s are numbered from 0 to N−1, and the root supplier’s ID is 0); P, the price given by the root supplier; and r, the percentage rate of price increment for each distributor or retailer. Then N lines follow, each describes a distributor or retailer in the following format:

K​i ID[1] ID[2] … ID[Ki]

where in the i-th line, K​i is the total number of distributors or retailers who receive products from supplier i, and is then followed by the ID’s of these distributors or retailers. K​j being 0 means that the j-th member is a retailer. All the numbers in a line are separated by a space.

Output Specification:
For each test case, print in one line the lowest price we can expect from some retailers, accurate up to 4 decimal places, and the number of retailers that sell at the lowest price. There must be one space between the two numbers. It is guaranteed that the all the prices will not exceed 10^10 .

Sample Input:
10 1.80 1.00
3 2 3 5
1 9
1 4
1 7
0
2 6 1
1 8
0
0
0

      
    
Sample Output:
1.8362 2

2 解析

2.1 题意

*给定销售供应树,树根唯一。求树最小叶子结点的价格以及个数。

2.2 思路

  • 1 用静态方法定义树
    • 由于无需用到结点权值,所以用vector<int> tree[MAXN]建立树
    • 结点编号为vector的第一维的下标,第二维存该结点的所有孩子结点编号
  • 2 DFS(先根)遍历树
    • 开一个全局数组numMin记录深度最小叶子结点的个数(初值为0)
    • 参数:目前遍历的结点编号:index;目前遍历结点的深度:depth;
    • 递归边界:index结点的孩子结点个数为0,更新最小的叶子结点层数depthMin,同时numMin[depthMin]++;
    • 递归式:对index的所有孩子结点进行遍历.
  • 3 输出:最低价格 = P * (1 + R) 叶结点最小层数 ,最低价格销售商数目:numMin[depthMin]++.

3 参考代码

#include <cstdio>
#include <vector>
#include <cmath>

using std::vector;

const int MAXN = 100010;
vector<int> tree[MAXN];

int N;
double P, R;
int numMin[MAXN] = {0};
int depthMin = MAXN;

void DFS(int index, int depth){
    if(tree[index].size() == 0){
        numMin[depth]++;
        if(depth < depthMin){
            depthMin = depth;
        }
        return;
    }

    for (int i = 0; i < tree[index].size(); ++i)
    {
        DFS(tree[index][i], depth + 1);
    }
}

int main(){
    scanf("%d%lf%lf", &N, &P, &R);
    R = R / 100;

    int k, child;
    for (int i = 0; i < N; ++i)
    {
        scanf("%d", &k);
        if(k != 0){
            for (int j = 0; j < k; ++j) {
                scanf("%d", &child);
                tree[i].push_back(child);
            }
        }
    }

    DFS(0,0);
    printf("%.4f %d\n", P * pow(1 + R, depthMin), numMin[depthMin]);

}

/*
10 1.80 1.00
3 2 3 5
1 9
1 4
1 7
0
2 6 1
1 8
0
0
0

 */
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

繁星蓝雨

如果觉得文章不错,可以请喝咖啡

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值