1014 Waiting in Line (30分)

1 题目

1014 Waiting in Line (30分)
Suppose a bank has N windows open for service. There is a yellow line in front of the windows which devides the waiting area into two parts. The rules for the customers to wait in line are:

The space inside the yellow line in front of each window is enough to contain a line with M customers. Hence when all the N lines are full, all the customers after (and including) the (NM+1)st one will have to wait in a line behind the yellow line.
Each customer will choose the shortest line to wait in when crossing the yellow line. If there are two or more lines with the same length, the customer will always choose the window with the smallest number.
Customer​i will take T​i minutes to have his/her transaction processed.
The first N customers are assumed to be served at 8:00am.
Now given the processing time of each customer, you are supposed to tell the exact time at which a customer has his/her business done.

For example, suppose that a bank has 2 windows and each window may have 2 customers waiting inside the yellow line. There are 5 customers waiting with transactions taking 1, 2, 6, 4 and 3 minutes, respectively. At 08:00 in the morning, customer​1 is served at window​1​​ while customer​2​​ is served at window​2​​ . Customer​3​​ will wait in front of window​1​​ and customer​4​​ will wait in front of window​2​​ . Customer​5​​ will wait behind the yellow line.

At 08:01, customer​1 is done and customer​5 enters the line in front of window1​​ since that line seems shorter now. Customer2​​ will leave at 08:02, customer4 at 08:06, customer3 at 08:07, and finally customer​5​​ at 08:10.

Input Specification:
Each input file contains one test case. Each case starts with a line containing 4 positive integers: N (≤20, number of windows), M (≤10, the maximum capacity of each line inside the yellow line), K (≤1000, number of customers), and Q (≤1000, number of customer queries).

The next line contains K positive integers, which are the processing time of the K customers.

The last line contains Q positive integers, which represent the customers who are asking about the time they can have their transactions done. The customers are numbered from 1 to K.

Output Specification:
For each of the Q customers, print in one line the time at which his/her transaction is finished, in the format HH:MM where HH is in [08, 17] and MM is in [00, 59]. Note that since the bank is closed everyday after 17:00, for those customers who cannot be served before 17:00, you must output Sorry instead.

Sample Input:
2 2 7 5
1 2 6 4 3 534 2
3 4 5 6 7

Sample Output:
08:07
08:06
08:10
17:00
Sorry

2 解析

2.1 题意

求查询顾客的结束服务时间,如果顾客开始服务时间大于或等于17:00,那么输出Sorry,否则输出结束服务的时间。

2.2 思路

设顾客i结束服务的时间为custormerFinish[i];

  • 1 由于要模拟每个窗口的排队情况,所以创建一个windows结构体,里面包含:当前窗口队首客服服务结束时间popTime,该窗口最后结束服务时间endTime,以及在当前窗口排队队列queue<int> q(里面包含顾客编号),每个窗口的endTime和popTime初始化为cal(8,0)(转换为分钟的函数);
  • 2 如果顾客数小于或等于窗口数* 每个窗口能容纳的最大排队长度,令index为目前填入的个数减1(初始为0),从不断把顾客加入0~N-1,0~N-1,…的窗口的排队队列,同时更新endTime、队列q(并把windows[index%n].endTime[作为customerFinish[index]存储),而popTime只有在每个窗口第一次进入顾客的时候,才计算(为第一个进入的顾客的结束服务的时间),在每次循环结束前index++;
  • 3 如果顾客数大于窗口数 * 每个窗口能容纳的最大排队长度,对于剩余的每个顾客(让index继续循环,直到小于K),选出当前窗口popTime最小的窗口编号,将队首顾客编号出队,将顾客排到该窗口的队列,更新endTime和popTime(将endTime作为该顾客结束服务的时间保存起来);
  • 4 对于查询的顾客,如果其开始服务的时间大于或等于17:00,则输出“Sorry”,否则输出该顾客结束服务的时间。

3 参考代码

#include <cstdio>
#include <cstring>
#include <cmath>
#include <queue>
#include <algorithm>

using std::min;
using  std::queue;
using std::fill;

struct Windows{
    int popTime;
    int endTime;
    queue<int> q;
}windows[21];
const int MAXN = 1111;
int customerServe[MAXN];
int endTime[MAXN];
int customerFinish[MAXN];

int calTime(int h, int m){
    return  h * 60 + m;
}

int main(int argc, char const *argv[])
{
    int n, m, k, q;
    scanf("%d%d%d%d", &n, &m, &k, &q);

    for (int i = 0; i < n; ++i)
    {
       windows[i].endTime = windows[i].popTime = calTime(8,0);
    }

    fill(customerFinish, customerFinish + k, 0);

    for (int i = 0; i < k; ++i)
    {
        scanf("%d", &customerServe[i]);
    }


    int index = 0;
    for (int i = 0; i < min(k, n * m); ++i) {
        windows[index % n].q.push(i);
        windows[index % n].endTime += customerServe[i];
        if(index < n){
            windows[index].popTime = customerServe[i];
        }
        customerFinish[i] = windows[index % n].endTime;
        index++;
    }

    for (;index < k; index++) {
        int idx = -1;
        int minPopTime = 1 << 30;
        for (int i = 0; i < n; ++i) {
            if(windows[i].popTime < minPopTime){
                minPopTime = windows[i].popTime;
                idx = i;
            }
        }

        Windows& W = windows[idx];
        W.q.pop();
        W.q.push(index);
        W.endTime += customerServe[index];
        W.popTime += customerServe[W.q.front()];
        customerFinish[index] = W.endTime;

    }


    for (int i = 0; i < q; ++i)
    {
        int query;
        scanf("%d", &query);
        if(customerFinish[query - 1] - customerServe[query -1] >= calTime(17,0)){
            printf("Sorry\n");
        }else{
            printf("%02d:%02d\n", customerFinish[query-1] / 60, customerFinish[query-1] % 60);
        }

    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

繁星蓝雨

如果觉得文章不错,可以请喝咖啡

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值