1065 A+B and C (64bit) (20 分)

Given three integers A, B and C in [−2​63​​,2​63​​], you are supposed to tell whether A+B>C.

Input Specification:

The first line of the input gives the positive number of test cases, T (≤10). Then T test cases follow, each consists of a single line containing three integers A, B and C, separated by single spaces.

Output Specification:

For each test case, output in one line Case #X: true if A+B>C, or Case #X: false otherwise, where X is the case number (starting from 1).

Sample Input:

3
1 2 3
2 3 4
9223372036854775807 -9223372036854775808 0

Sample Output:

Case #1: false
Case #2: true
Case #3: false

参考代码:

//甲练 A+B and C
#include<stdio.h>
int main(int argc, char const *argv[])
{
	int N;
	bool flag;
	int count = 1;
	scanf("%d",&N);
	
	while(N--){
		long long A,B,C;
	scanf("%lld%lld%lld",&A,&B,&C);
	long long res = A + B;

	if(A > 0 && B > 0 && res < 0 ) flag = true;
	else if(A < 0 && B < 0 && res >= 0 ) flag = false;
	else if(res > C) flag = true;
	else flag = false;

	if(flag == true) printf("Case #%d: true\n",count++);
	else printf("Case #%d: false\n",count++);

	}
	
	return 0;
}

题目原理分析:

因为A,B,C的范围为[-2^63,2^63],而long long的取值范围为[-2^63,2^63],所以相加会存在溢出的问题

1,当A+B>=2^63时,显然A+B>C成立,但是A+B会超过long long的最大值,发生溢出,而A、B的最大值为2^63-1,所以A+B的最大值为2^64-2,所以使用long long存储后后溢出的值的区间为[-2^63,-2],【-2=(2^64-2)%2^64】

2,当A+B<-2^63时,显然A+B<C成立,但是A+B会超过long long的最大值,发生溢出,而A、B的最小值为-2^63,所以A+B的最小值为-2^64,所以使用long long存储后溢出的值的区间为[0,2^63),【0=(-2^64)】%2^64】

 

延伸;使用long double ,就不会产生溢出。

 

 

评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

繁星蓝雨

如果觉得文章不错,可以请喝咖啡

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值