SDAU 课程练习3 1019

Problem S

Time Limit : 10000/5000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 19   Accepted Submission(s) : 7
Problem Description
Nowadays, we all know that Computer College is the biggest department in HDU. But, maybe you don't know that Computer College had ever been split into Computer College and Software College in 2002.<br>The splitting is absolutely a big event in HDU! At the same time, it is a trouble thing too. All facilities must go halves. First, all facilities are assessed, and two facilities are thought to be same if they have the same value. It is assumed that there is N (0&lt;N&lt;1000) kinds of facilities (different value, different kinds).<br>
 

Input
Input contains multiple test cases. Each test case starts with a number N (0 < N <= 50 -- the total number of different facilities). The next N lines contain an integer V (0<V<=50 --value of facility) and an integer M (0<M<=100 --corresponding number of the facilities) each. You can assume that all V are different.<br>A test case starting with a negative integer terminates input and this test case is not to be processed.<br>
 

Output
For each case, print one line containing two integers A and B which denote the value of Computer College and Software College will get respectively. A and B should be as equal as possible. At the same time, you should guarantee that A is not less than B.<br>
 

Sample Input
  
  
2 10 1 20 1 3 10 1 20 2 30 1 -1
 

Sample Output
  
  
20 10 40 40
 
题目大意:

计算机学院分家。现在有价值为  vol 的电脑  n  台,求尽可能平分可以得到的价值。如果平分的价值不相等,先输出大的那一个。
这个题比较坑的就是,不是输入-1 结束,而是输入负数结束.......  mdzz

思路:

转化成独立的物品,比如  20  2  等加成价值两件  价值 20 的物品。
然后取总价值的一半作为背包容量进行0 1 求解。

感想:

这个题的状态一定要赋好。其他的就很正常啦。

AC代码:

#include<iostream>
#include<cmath>
#include<string.h>
using namespace std;
int main()
{
    int t,n,m,i,j,k,z,sum,mid;
    int dp[100005];
    int a[100005];
    while(cin>>t)
    {
        if(t<0) break;
        memset(dp,0,sizeof(dp));
        sum=0;k=0;
        for(i=0;i<t;i++)
        {
            cin>>n>>m;
            sum+=n*m;
            for(j=0;j<m;j++)
            {
                a[k++]=n;
            }
        }
        mid=sum/2;
        for(i=0;i<k;i++)
        {
            for(j=mid;j>=a[i];j--)
            {
                dp[j]=max(dp[j],dp[j-a[i]]+a[i]);
            }
        }
        cout<<sum-dp[mid]<<" "<<dp[mid]<<endl;
    }
    return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值