HDU ACM—STEP 3.3.7二维背包

Watch The Movie

Time Limit: 3000/1000 MS (Java/Others) Memory Limit: 65535/65535 K (Java/Others)
Total Submission(s): 789 Accepted Submission(s): 291
 
Problem Description
New semester is coming, and DuoDuo has to go to school tomorrow. She decides to have fun tonight and will be very busy after tonight. She like watch cartoon very much. So she wants her uncle to buy some movies and watch with her tonight. Her grandfather gave them L minutes to watch the cartoon. After that they have to go to sleep.
DuoDuo list N piece of movies from 1 to N. All of them are her favorite, and she wants her uncle buy for her. She give a value Vi (Vi > 0) of the N piece of movies. The higher value a movie gets shows that DuoDuo likes it more. Each movie has a time Ti to play over. If a movie DuoDuo choice to watch she won’t stop until it goes to end.
But there is a strange problem, the shop just sell M piece of movies (not less or more then), It is difficult for her uncle to make the decision. How to select M piece of movies from N piece of DVDs that DuoDuo want to get the highest value and the time they cost not more then L.
How clever you are! Please help DuoDuo’s uncle.
 
Input
The first line of the input file contains a single integer t (1 ≤ t ≤ 10), the number of test cases, followed by input data for each test case:
The first line is: N(N <= 100),M(M<=N),L(L <= 1000)
N: the number of DVD that DuoDuo want buy. 
M: the number of DVD that the shop can sale.
L: the longest time that her grandfather allowed to watch.
The second line to N+1 line, each line contain two numbers. The first number is the time of the ith DVD, and the second number is the value of ith DVD that DuoDuo rated.
 
Output
Contain one number. (It is less then 2^31.)
The total value that DuoDuo can get tonight.
If DuoDuo can’t watch all of the movies that her uncle had bought for her, please output 0.
 
Sample Input
1
3 2 10
11 100
1 2
9 1
 
Sample Output
3
 
 
Source
2010 ACM-ICPC Multi-University Training Contest(6)——Host by BIT
 
Recommend
zhouzeyong
 

题目大意:

给出 n组 个数据    他只能选  u 个,背包容量  v
每组数据给出  体积 价值

思路:

第一次写二维费用的背包题目。
大致模板是这样的

for(i=0;i<n;i++)
        {
            for(j=u;j>=1;j--)
            {
                for(k=v;k>=cost[i];k--)
                {
              
                    dp[j][k]=max(dp[j][k],(dp[j-1][k-cost[i]]+weight[i]));
                }
            }
        }
对于第 i 件物品 u  和 v  分别是选择这件物品的两种费用。然后。。。。注意处理边界。这个题居然有价值为负数的情况。。。。尴尬。

感想:

刷了一上午了,累死了。

AC代码:

#include<iostream>
#include<string.h>
#include<algorithm>
using namespace std;
int v;
int dp[105][1005];
int main()
{
    int T,n,i,k,j;
    cin>>T;
    while(T--)
    {
        int n,u,v;
        cin>>n>>u>>v;
        int cost[1005],weight[1005];
        for(i=0;i<n;i++)
        {
            cin>>cost[i]>>weight[i];
        }
        for(i=0;i<=u;i++)
        {
            for(j=0;j<=v;j++)
            {
                if(i==0)
                    dp[i][j]=0;
                else
                    dp[i][j]=-999999;
            }
        }
        for(i=0;i<n;i++)
        {
            for(j=u;j>=1;j--)
            {
                for(k=v;k>=cost[i];k--)
                {
                    //if(dp[j][k]>(dp[j-1][k-cost[i]]+weight[i]))
                        //dp[j][k]=(dp[j-1][k-cost[i]]+weight[i]);
                    dp[j][k]=max(dp[j][k],(dp[j-1][k-cost[i]]+weight[i]));
                }
            }
        }
        if(dp[u][v]<0)
            dp[u][v]=0;
        cout<<dp[u][v]<<endl;
    }
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值