hdu1312

Problem Description
There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above.
 

Input
The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

'.' - a black tile
'#' - a red tile
'@' - a man on a black tile(appears exactly once in a data set)
 

Output
For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).
 

Sample Input
  
  
6 9 ....#. .....# ...... ...... ...... ...... ...... #@...# .#..#. 11 9 .#......... .#.#######. .#.#.....#. .#.#.###.#. .#.#..@#.#. .#.#####.#. .#.......#. .#########. ........... 11 6 ..#..#..#.. ..#..#..#.. ..#..#..### ..#..#..#@. ..#..#..#.. ..#..#..#.. 7 7 ..#.#.. ..#.#.. ###.### ...@... ###.### ..#.#.. ..#.#.. 0 0
 

Sample Output
  
  
45 59 6 13
 


DFS水题,看清题目要求即可

代码:

#include<iostream>
#include<string>
#include<cstring>
#include<cmath>
#include<algorithm>
#include<stdio.h>
using namespace std;
int cnt;
int W,H;
int x,y;
char array[21][21];
int temp[4][2] = {{1,0},{0,1},{-1,0},{0,-1}};
void DFS(int a,int b)
{
        cnt++;
        array[a][b] = '#';        
        for(int i = 0;i < 4;i++)
        {
            int xx = temp[i][0] + a;
            int yy = temp[i][1] + b;
            if(xx >= 0&&xx < H&&yy >= 0 && yy < W&&array[xx][yy] == '.')
            DFS(xx,yy);
        }
        return;
}
int main()
{
    int i,j,k;
    while(~scanf("%d%d",&W,&H))
    {
        if(W == 0&& H == 0)
        break;
        for(i = 0;i < H;i++)
        {
            for(j = 0;j < W;j++)
            {
                cin>>array[i][j];
                if(array[i][j] == '@')
                {
                    x = i,y = j;
                }
            }
        }
    
        cnt = 0;
        DFS(x,y);
        cout<<cnt<<endl;
    }
    
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值