并查集 - 畅通工程

题目描述

某省调查城镇交通状况,得到现有城镇道路统计表,表中列出了每条道路直接连通的城镇。省政府“畅通工程”的目标是使全省任何两个城镇间都可以实现交通(但不一定有直接的道路相连,只要互相间接通过道路可达即可)。问最少还需要建设多少条道路?

输入

测试输入包含若干测试用例。每个测试用例的第1行给出两个正整数,分别是城镇数目N(N<1000)和道路数目M;随后的M行对应M条道路,每行给出一对正整数,分别是该条道路直接连通的两个城镇的编号。为简单起见,城镇从1到N编号。 

注意:两个城市之间可以有多条道路相通,也就是说:

3 3

1 2

1 2

2 1

这种输入也是合法的

当N为0时,输入结束,该用例不被处理。 


输出

对每个测试用例,在1行里输出最少还需要建设的道路数目。

样例输入

4 2
1 3
4 3
3 3
1 2
1 3
2 3
5 2
1 2
3 5
999 0
0

样例输出

1
0
2
998



#include<cstdio>
#include<cmath>
#include<cstring>
#include<iostream>
#include<cstdlib>
#include<algorithm>
#include<string>
#include<vector>
#include<queue>
#include<stack>
#include<set>
#include<list>

using namespace std;
const int N = 1005;
int towns[N];

int find(int t)
{
	if (towns[t] == -1) return t;
	return towns[t] = find(towns[t]);
}
void bing(int a, int b)
{
	int t1 = find(a);
	int t2 = find(b);
	if (t1 != t2) towns[t1] = t2;
}
int main()
{
	int n, m;
	while (cin >> n ,n)
	{
		cin >> m;
		memset(towns, -1, sizeof(towns));
		int ans = 0;
		for (int i = 0; i < m; i++)
		{
			int a, b;
			cin >> a >> b;
			bing(a, b);
		}
		for (int i = 1; i <= n; i++)
			if (towns[i] == -1) ans++;
		cout << ans-1 << endl;
	}
	return 0;
}

解法转自  http://www.cnblogs.com/kuangbin/archive/2012/07/29/2613773.html


以下代码为floyd算法,求传递闭包。但是速度较慢会超时。

#include<cstdio>
#include<cmath>
#include<cstring>
#include<iostream>
#include<cstdlib>
#include<algorithm>
#include<string>
#include<vector>
#include<queue>
#include<stack>
#include<set>
#include<list>

using namespace std;
const int N = 1000;
int towns[N][N];
int main()
{
	int n, m;
	while (cin >> n, n)
	{
		cin >> m;
		memset(towns, 0, sizeof(towns));
		int ans = 0;
		for (int i = 0; i < m; i++)
		{
			int a, b;
			cin >> a >> b;
			towns[b - 1][a - 1] = towns[a - 1][b - 1] = 1;
		}

		/*for (int i = 0; i < n; i++)
		{
		for (int j = 0; j < n; j++)
		cout << towns[i][j] << " ";
		cout << endl;
		}
		cout << endl;*/


		/*for (int k = 0; k < n; k++)
		for (int i = 0; i < n; i++)
		{
		for (int j = 0; j < n; j++)
		towns[i][j] = towns[i][j] || (towns[i][k] && towns[k][j]);
		//增加路线
		for (int j = 0; j < n; j++)
		if (towns[i][j] == 0) { towns[i][j] = towns[j][i] = 1; ans++; }

		}*/
		for (int i = 0; i < n; i++)
			for (int j = 0; j < n; j++)
			{
				for (int k = 0; k < n; k++)
					towns[i][j] = towns[i][j] || (towns[i][k] && towns[k][j]);
				if (towns[i][j] == 0) { towns[i][j] = towns[j][i] = 1; ans++; }
			}


		/*for (int i = 0; i < n; i++)
		{
		for (int j = 0; j < n; j++)
		cout << towns[i][j] << " ";
		cout << endl;
		}
		cout << endl;*/

		cout << ans << endl;
	}
	return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值