Code Forces 587 A. Duff and Weight Lifting

A. Duff and Weight Lifting
time limit per test
1 second
memory limit per test
256 megabytes
input
standard input
output
standard output

Recently, Duff has been practicing weight lifting. As a hard practice, Malek gave her a task. He gave her a sequence of weights. Weight of i-th of them is 2wi pounds. In each step, Duff can lift some of the remaining weights and throw them away. She does this until there’s no more weight left. Malek asked her to minimize the number of steps.

Duff is a competitive programming fan. That’s why in each step, she can only lift and throw away a sequence of weights 2a1, …, 2ak if and only if there exists a non-negative integer x such that 2a1 + 2a2 + … + 2ak = 2x, i. e. the sum of those numbers is a power of two.

Duff is a competitive programming fan, but not a programmer. That’s why she asked for your help. Help her minimize the number of steps.
Input

The first line of input contains integer n (1 ≤ n ≤ 106), the number of weights.

The second line contains n integers w1, …, wn separated by spaces (0 ≤ wi ≤ 106 for each 1 ≤ i ≤ n), the powers of two forming the weights values.
Output

Print the minimum number of steps in a single line.
Examples
Input

5
1 1 2 3 3

Output

2

Input

4
0 1 2 3

Output

4

Note

In the first sample case: One optimal way would be to throw away the first three in the first step and the rest in the second step. Also, it’s not possible to do it in one step because their sum is not a power of two.

In the second sample case: The only optimal way is to throw away one weight in each step. It’s not possible to do it in less than 4 steps because there’s no subset of weights with more than one weight and sum equal to a power of two.

题目大意:
Description
达夫每天练习举重,教练给了她n个重量值为2^wi哑铃让她举,每次达夫可以举起满足2^a1+2^a2+…+2^ak=2^x的重量并将这些哑铃扔掉,问达夫最少几次完成教练的任务
Input
第一行为一整数n表示哑铃数,第二行n个整数wi表示第i个哑铃重2^wi
Output
输出达夫最少几次能完成任务
Sample Input
5
1 1 2 3 3
Sample Output
2
Solution
首先开一个数组记录WI的出现次数,然后贪心,每次让WI=(WI-1)/2,WI=WI%2;更新完后再统计一边有多少个1就好了,但是要注意数组需要开大一点,因为如果所有数据都是10^6,那么应该会需要10^6+log2 (10^6)这么大的数组

#include<stdio.h>
#include<string.h>
#define maxn 2000000
int n,w,cnt_w[maxn],ans;
int main()
{
    while(~scanf("%d",&n))
    {
        memset(cnt_w,0,sizeof(cnt_w));
        ans=0;
        for(int i=0;i<n;i++)
        {
            scanf("%d",&w);
            cnt_w[w]++;
        }
        for(int i=1;i<maxn;i++)//合并 
            cnt_w[i]+=(cnt_w[i-1]/2),cnt_w[i-1]%=2;
        for(int i=0;i<maxn;i++)//剩下的就是每次需要举的重量 
            ans+=cnt_w[i];
        printf("%d\n",ans);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值