HDU - 3032 Nim or not Nim?

14 篇文章 0 订阅
11 篇文章 0 订阅

Nim or not Nim?

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2238 Accepted Submission(s): 1158

Problem Description
Nim is a two-player mathematic game of strategy in which players take turns removing objects from distinct heaps. On each turn, a player must remove at least one object, and may remove any number of objects provided they all come from the same heap.

Nim is usually played as a misere game, in which the player to take the last object loses. Nim can also be played as a normal play game, which means that the person who makes the last move (i.e., who takes the last object) wins. This is called normal play because most games follow this convention, even though Nim usually does not.

Alice and Bob is tired of playing Nim under the standard rule, so they make a difference by also allowing the player to separate one of the heaps into two smaller ones. That is, each turn the player may either remove any number of objects from a heap or separate a heap into two smaller ones, and the one who takes the last object wins.

Input
Input contains multiple test cases. The first line is an integer 1 ≤ T ≤ 100, the number of test cases. Each case begins with an integer N, indicating the number of the heaps, the next line contains N integers s[0], s[1], …., s[N-1], representing heaps with s[0], s[1], …, s[N-1] objects respectively.(1 ≤ N ≤ 10^6, 1 ≤ S[i] ≤ 2^31 - 1)

Output
For each test case, output a line which contains either “Alice” or “Bob”, which is the winner of this game. Alice will play first. You may asume they never make mistakes.

Sample Input
2
3
2 2 3
2
3 3

Sample Output
Alice
Bob

Source
2009 Multi-University Training Contest 13 - Host by HIT

Recommend
gaojie

数据比较大,肯定有规律,先对sg打表,然后找规律:
求sg:

#include<bits/stdc++.h>
using namespace std;
int sg[1005],mex[1005];
void f()
{
    memset(sg,0,sizeof(sg));

    sg[0]=0;
    for(int n=1;n<1000;n++)
    {
        memset(mex,0,sizeof(mex));
        for(int i=n-1;i>=0;i--) mex[sg[i]]=1;
        for(int i=1;i<=n/2;i++)
        {
            int ans=0;
            ans^=sg[i];
            ans^=sg[n-i];
            mex[ans]=1;
        }
        for(int i=0;;i++)
            if(!mex[i]) {sg[n]=i;break;}
    }
}

int main()
{
    f();
    for(int i=0;i<100;i++)
        cout<<"i="<<i<<' '<<sg[i]<<endl;
}

规律很明显,当sg[4k]=4k-1,sg[4k-1]=4k;
ac代码:

#include<bits/stdc++.h>
using namespace std;
int main()
{
    long long n,k,t;
    long long ans=0;
    cin>>t;
    while(t--)
    {
        cin>>n;
        ans=0;
        for(long long i=0;i<n;i++)
        {
            scanf("%lld",&k);
            if(k==0) ans^=0;
            else if(k%4==0) ans^=(k-1);
            else if(k%4==3) ans^=(k+1);
            else ans^=k;
        }
        if(ans) cout<<"Alice"<<endl;
        else cout<<"Bob"<<endl;
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值