17暑假多校第一场B

14 篇文章 0 订阅
8 篇文章 0 订阅

Balala Power!

Time Limit: 4000/2000 MS (Java/Others) Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 4809 Accepted Submission(s): 387

Problem Description

Talented Mr.Tang has n strings consisting of only lower case characters. He wants to charge them with Balala Power (he could change each character ranged from a to z into each number ranged from 0 to 25, but each two different characters should not be changed into the same number) so that he could calculate the sum of these strings as integers in base 26 hilariously.

Mr.Tang wants you to maximize the summation. Notice that no string in this problem could have leading zeros except for string “0”. It is guaranteed that at least one character does not appear at the beginning of any string.

The summation may be quite large, so you should output it in modulo 109+7.

Input
The input contains multiple test cases.

For each test case, the first line contains one positive integers n, the number of strings. (1≤n≤100000)

Each of the next n lines contains a string si consisting of only lower case letters. (1≤|si|≤100000,∑|si|≤106)

Output
For each test case, output “Case #x: y” in one line (without quotes), where x indicates the case number starting from 1 and y denotes the answer of corresponding case.

Sample Input
1
a
2
aa
bb
3
a
ba
abc

Sample Output
Case #1: 25
Case #2: 1323
Case #3: 18221

其实这题思路还是很好想的,主要是代码,,,

官方题解:每个字符对答案的贡献都可以看作一个 26 进制的数字,问题相当于要给这些贡献加一个 0 到 25 的权重使得答案最大。最大的数匹配 25,次大的数匹配 24,依次类推。排序后这样依次贪心即可,唯一注意的是不能出现前导 0。

#include<bits/stdc++.h>
using namespace std;
string s;
int asleader[26],num[26][101005],len[26],A[26],score[26];
long long MOD=1e9+7;
int cmp(int x,int y){
    int i;
    if(len[x]>len[y]) return 1;
    if(len[x]<len[y]) return 0;
    for(i=len[x];i>=0;i--){
        if(num[x][i]>num[y][i]){
            return 1;
        }
        else if(num[x][i]<num[y][i]){
            return 0;
        }
    }
    return 0;
}
long long cal(){
    int i,j;
    long long sum=0,res;
    for(j=0;j<26;j++){
        res=0;
        for(i=len[j];i>0;i--){
            res*=26;
            res+=(score[j]*num[j][i]);
            res%=MOD;
        }
        sum+=res;
        sum%=MOD;
    }
    return sum;
}
void add(int x,int y){
    len[x]=max(len[x],y);
    if(num[x][y]>=26){
        num[x][y+1]+=(num[x][y]/26);
        num[x][y]%=26;
        add(x,y+1);
    }
}
char ss[100005];
int main(void){
    int i,j,n,m,ca=1,LEN,t;
    while(scanf("%d",&n)!=EOF){
        for(i=0;i<26;i++)
            A[i]=i;
        memset(num,0,sizeof(num));
        memset(len,0,sizeof(len));
        memset(asleader,0,sizeof(asleader));
        for(i=0;i<n;i++){
            scanf("%s",ss);
            s=ss;
            asleader[s[0]-'a']=1;
            LEN=s.size();
            for(j=s.size()-1;j>=0;j--){
                num[s[j]-'a'][LEN-j]++;
                add(s[j]-'a',LEN-j);
            }
        }
        for(i=0;i<26;i++){
            for(j=1;j<26;j++){
                if(cmp(A[j-1],A[j])==0){
                    swap(A[j-1],A[j]);
                }
            }
        }
        for(i=25;;i--){
            if(asleader[A[i]]==0){
                t=A[i];
                for(j=i;j<25;j++){
                    A[j]=A[j+1];
                }
                A[25]=t;
                break;
            }
        }

        for(i=0;i<26;i++){
            score[A[i]]=25-i;
        }
        printf("Case #%d: %lld\n",ca++,cal());
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值