Linux下安装Oracle报错:Error in invoking target 'mkldflags ntcontab.o&nb

linux小红帽下安装oracle是十分痛苦的,因为默认是没有gcc和gcc-c++环境的,这个需要自己安装,当然这个前提是在上步你的包没有缺失,当遇到Error in invoking target 'mkldflags ntcontab.o&nb  这个问题时;直接安装gcc和gcc-c++环境:

  • 首先你得先把镜像上传安装:这个根据自己的版本
  • 将镜像挂载到/mnt目录下:

    # cd /mnt

    # mkdir cd

    # mount /dev/cdrom  /mnt/cd

  • # /mnt/cd/Packages

  • 开始安装gcc环境顺序不能错:

    rpm -ivh glibc-common-2.12-1.132.el6.x86_64.rpm

    rpm -ivh kernel-headers-2.6.32-431.el6.x86_64.rpm

    rpm -ivh libgcc-4.4.7-4.el6.x86_64.rpm

    rpm -ivh glibc-2.12-1.132.el6.x86_64.rpm

    rpm -ivh libgomp-4.4.7-4.el6.x86_64.rpm

    rpm -ivh nscd-2.12-1.132.el6.x86_64.rpm

    rpm -ivh glibc-headers-2.12-1.132.el6.x86_64.rpm

    rpm -ivh glibc-devel-2.12-1.132.el6.x86_64.rpm

    rpm -ivh mpfr-2.4.1-6.el6.x86_64.rpm

    rpm -ivh ppl-0.10.2-11.el6.x86_64.rpm

    rpm -ivh cloog-ppl-0.15.7-1.2.el6.x86_64.rpm

    rpm -ivh cpp-4.4.7-4.el6.x86_64.rpm

    rpm -ivh gcc-4.4.7-4.el6.x86_64.rpm

  • 开始安装gcc-c++环境:

    rpm -ivh libstdc++-4.4.7-4.el6.x86_64.rpm

    rpm -ivh libstdc++-devel-4.4.7-4.el6.x86_64.rpm

    rpm -ivh gcc-c++-4.4.7-4.el6.x86_64.rpm

  • 如果要是版本不一样可以用ls | grep 包名 来查询自己版本所对应的rpm包。再用rpm -ivh 包名 进行安装。

  • 祝各位早日脱坑哈哈哈

  • 0
    点赞
  • 5
    收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
©️2022 CSDN 皮肤主题:书香水墨 设计师:CSDN官方博客 返回首页
评论

打赏作者

浪灬迹-红尘少年

你的鼓励将是我创作的最大动力

¥2 ¥4 ¥6 ¥10 ¥20
输入1-500的整数
余额支付 (余额:-- )
扫码支付
扫码支付:¥2
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、C币套餐、付费专栏及课程。

余额充值