DFS——poj1979(深度优先搜索 )

Description

There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles. 

Write a program to count the number of black tiles which he can reach by repeating the moves described above. 

Input

The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20. 

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows. 

'.' - a black tile 
'#' - a red tile 
'@' - a man on a black tile(appears exactly once in a data set) 
The end of the input is indicated by a line consisting of two zeros. 

Output

For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).

Sample Input

6 9
....#.
.....#
......
......
......
......
......
#@...#
.#..#.
11 9
.#.........
.#.#######.
.#.#.....#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#.......#.
.#########.
...........
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
...@...
###.###
..#.#..
..#.#..
0 0

Sample Output

45
59
6
13

大致题目描述:

有一个长方形的房间,覆盖着方形的瓷砖。每瓦颜色是红色或黑色。一个男人站在一个黑色的瓷砖上。从一个瓷砖,他可以移动到四个相邻的瓷砖之一。但他不能在红色的瓷砖上移动,他只能在黑色的瓷砖上移动。
编写一个程序来计数的数量,他可以达到通过重复上述动作所描述的黑砖。


代码:

#include<stdio.h>  
#include<stdlib.h>  
#include<string.h>  
#define MAX 20  
int W, H;  
char a[MAX][MAX];  
int count = 0;  
int dx[4] = {1,0,-1,0},dy[4]={0,1,0,-1};  
int x,y;  
void dfs(int nx, int ny)  
{  
     if(nx >= 0 && nx < H && ny >= 0 && ny < W && a[nx][ny] =='.')  
     {  
         a[nx][ny] = '#';  
         count++;  
     }  
     else  
         return;  
    for(int i = 0; i < 4; i++)  
    {  
        x = nx + dx[i];  
        y = ny + dy[i];  
        if(a[x][y]=='.')  
        {  
            dfs(x,y);  
        }  
    }     
       
}     
  
int main()  
{  
    int nx=0,ny=0;  
    while(scanf("%d%d\n",&W, &H) && (W || H))  
    {  
        for(int i=0; i<H; i++)  
        {  
            for(int j=0; j<W; j++)  
            {  
                scanf("%c",&a[i][j]);  
                if(a[i][j]=='@')  
                {  
                    nx = i;  
                    ny = j;  
                }  
            }  
            getchar();  
        }  
        a[nx][ny] = '.';  
        dfs(nx,ny);  
        printf("%d\n",count++);  
        count=0;  
    }  
    return 0;  
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值