习题11-7 奇数值结点链表

本题要求实现两个函数,分别将读入的数据存储为单链表、将链表中奇数值的结点重新组成一个新的链表。链表结点定义如下:

struct ListNode {
    int data;
    ListNode *next;
};

函数接口定义:

struct ListNode *readlist(); struct ListNode *getodd( struct ListNode **L );

函数readlist从标准输入读入一系列正整数,按照读入顺序建立单链表。当读到−1时表示输入结束,函数应返回指向单链表头结点的指针。

函数getodd将单链表L中奇数值的结点分离出来,重新组成一个新的链表。返回指向新链表头结点的指针,同时将L中存储的地址改为删除了奇数值结点后的链表的头结点地址(所以要传入L的指针)。

裁判测试程序样例:

#include <stdio.h>
#include <stdlib.h>

struct ListNode {
    int data;
    struct ListNode *next;
};

struct ListNode *readlist();
struct ListNode *getodd( struct ListNode **L );
void printlist( struct ListNode *L )
{
     struct ListNode *p = L;
     while (p) {
           printf("%d ", p->data);
           p = p->next;
     }
     printf("\n");
}

int main()
{
    struct ListNode *L, *Odd;
    L = readlist();
    Odd = getodd(&L);
    printlist(Odd);
    printlist(L);

    return 0;
}

/* 你的代码将被嵌在这里 */

输入样例:

1 2 2 3 4 5 6 7 -1

输出样例:

1 3 5 7 
2 2 4 6
struct ListNode *readlist(){
	int n;
	struct ListNode *head,*tail;
	head=tail=NULL;
	scanf("%d",&n);
	while(n!=-1){
		struct ListNode *p=(struct ListNode *)malloc(sizeof(struct ListNode));
		p->data=n;
		p->next=NULL;
		if(head==NULL)
			head=tail=p;
		else{
			tail->next=p;
			tail=p;
		}
		scanf("%d",&n);
	}
	return head;
	
}
struct ListNode *getodd( struct ListNode **L ){
	
	struct ListNode *sp=*L,*ohead=sp;
	struct ListNode *nhead=NULL;
	struct ListNode *p1,*p2,*ntail;
	
	//要删除节点为表头节点
	while(ohead!=NULL&&ohead->data%2!=0){
		p2=ohead;
		ohead=ohead->next;
		
		if(nhead==NULL){//新表 
				nhead=ntail=p2;
				ntail->next=NULL;
				
			}else{
				ntail->next=p2;
				ntail=p2;
				ntail->next=NULL;
		}
		
	}
	if(ohead==NULL){//旧链表为空
		*L=ohead; 
		return nhead;
	}
	//要删除节点为非表头节点
	p1=ohead;
	p2=ohead->next;
	
	while(p2!=NULL){
		if(p2->data%2!=0){
			p1->next=p2->next;
			
			if(nhead==NULL){//新表 
				nhead=ntail=p2;
				ntail->next=NULL;
				
			}else{
				ntail->next=p2;
				ntail=p2;
				ntail->next=NULL;
			}
			
		}else
			p1=p2;
		p2=p1->next;
		
	}
	*L=ohead; 
	return nhead;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值