案例4-1.7 文件传输

当两台计算机双向连通的时候,文件是可以在两台机器间传输的。给定一套计算机网络,请你判断任意两台指定的计算机之间能否传输文件?

输入格式:

首先在第一行给出网络中计算机的总数 N (2≤N≤104),于是我们假设这些计算机从 1 到 N 编号。随后每行输入按以下格式给出:

I c1 c2  

其中I表示在计算机c1c2之间加入连线,使它们连通;或者是

C c1 c2    

其中C表示查询计算机c1c2之间能否传输文件;又或者是

S

这里S表示输入终止。

输出格式:

对每个C开头的查询,如果c1c2之间可以传输文件,就在一行中输出"yes",否则输出"no"。当读到终止符时,在一行中输出"The network is connected."如果网络中所有计算机之间都能传输文件;或者输出"There are k components.",其中k是网络中连通集的个数。

输入样例 1:

5
C 3 2
I 3 2
C 1 5
I 4 5
I 2 4
C 3 5
S

输出样例 1:

no
no
yes
There are 2 components.

输入样例 2:

5
C 3 2
I 3 2
C 1 5
I 4 5
I 2 4
C 3 5
I 1 3
C 1 5
S

输出样例 2:

no
no
yes
yes
The network is connected.

代码实现 

其中的路径压缩算法中,我们递归的把X的父节点S[X]设置为对其当前父节点S[X]执行find的结果,并切返回更新后的父节点值。

#include <stdio.h>

#define MaxSize 10000
typedef int ElementType;
typedef int SetName;

/*-----集合定义-----*/ 
typedef ElementType SetType[MaxSize];
void Initialization( SetType S , int n );
void Union( SetType S, SetName Root1, SetName Root2 );
SetName Find( SetType S, ElementType X  );
/*-----集合定义结束-----*/ 

void Input_connection( SetType S );
void Check_connection( SetType S );
void Check_network( SetType S , int n );
 
int main()
{
    SetType S;
    int n;
    char in;
    
    scanf("%d\n", &n);
    Initialization( S, n );
    do {
        scanf("%c", &in);
        switch (in) {
            case 'I': Input_connection( S ); break;
            case 'C': Check_connection( S ); break;
            case 'S': Check_network( S, n ); break;
        }
    } while ( in != 'S');
    return 0;
}
void Initialization( SetType S , int n )
{
	int  i;

	for ( i=0; i<n; i++ )
		S[i] = -1;
}
void Union( SetType S, SetName Root1, SetName Root2 )
{

	if ( S[Root2] < S[Root1] ) { 
		S[Root2] += S[Root1];	 
		S[Root1] = Root2;		 
	}
	else {						
		S[Root1] += S[Root2];	 
		S[Root2] = Root1;		
	}
}

SetName Find( SetType S, ElementType X  )
{ 
	if ( S[X] < 0 )
		return X;
	else
		return S[X] = Find( S, S[X] ); 
}
void Input_connection( SetType S )
{
    ElementType u, v;
    SetName Root1, Root2;
     
    scanf("%d %d\n", &u, &v);
    Root1 = Find(S, u-1);
    Root2 = Find(S, v-1);
    if ( Root1 != Root2 )
        Union( S, Root1, Root2 );
}

void Check_connection( SetType S )
{
	ElementType u, v;
	SetName Root1, Root2;

	scanf("%d %d\n", &u, &v);
    Root1 = Find(S, u-1);
    Root2 = Find(S, v-1);
	if ( Root1 == Root2 )
		printf("yes\n");
	else
		printf("no\n");
}

void Check_network( SetType S , int n )
{
	int  i, counter = 0;

	for (i=0; i<n; i++) {
		if ( S[i] < 0 )
			counter ++;
	}
	if ( counter == 1 )
		printf("The network is connected.\n");
	else
		printf("There are %d components.\n", counter);
}

 

  • 4
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值