PAT甲级查找元素1036 Boys vs Girls

  • 要考虑为零的情况! 

  • 初始化不能在可能取值范围内!

  • scanf字符要用&

  • 复制一时爽,挑错很绝望!

This time you are asked to tell the difference between the lowest grade of all the male students and the highest grade of all the female students.

Input Specification:

Each input file contains one test case. Each case contains a positive integer N, followed by N lines of student information. Each line contains a student's namegenderID and grade, separated by a space, where name and ID are strings of no more than 10 characters with no space, gender is either F (female) or M (male), and grade is an integer between 0 and 100. It is guaranteed that all the grades are distinct.

Output Specification:

For each test case, output in 3 lines. The first line gives the name and ID of the female student with the highest grade, and the second line gives that of the male student with the lowest grade. The third line gives the difference grade​F​​−grade​M​​. If one such kind of student is missing, output Absent in the corresponding line, and output NA in the third line instead.

Sample Input 1:

3
Joe M Math990112 89
Mike M CS991301 100
Mary F EE990830 95

Sample Output 1:

Mary EE990830
Joe Math990112
6

Sample Input 2:

1
Jean M AA980920 60

Sample Output 2:

Absent
Jean AA980920
NA
#include<bits/stdc++.h>
using namespace std;
struct stu{
    char name[11],gen,id[11];
    int grade;
}sm,sf,s;
int main(){
    int n;
    sm.gen = 'N',sf.gen = 'N';
    sm.grade = 101,sf.grade=-1;//初始值
    scanf("%d",&n);
    for(int i=0;i<n;i++){
        scanf("%s %c %s %d",s.name,&s.gen,s.id,&s.grade);//字符串要加&符号
        if(s.gen=='M'&&s.grade<sm.grade)sm = s;
        else if(s.gen=='F'&&s.grade>sf.grade)sf = s;//你知道吗,复制代码就很容易有疏漏哦
    }

    if(sf.gen!='N')
    cout<<sf.name<<" "<<sf.id<<"\n";
    else cout<<"Absent\n";
    if(sm.gen!='N')
    cout<<sm.name<<" "<<sm.id<<"\n";
    else cout<<"Absent\n";
    if(sm.gen!='N'&&sf.gen!='N')
    cout<<sf.grade - sm.grade;
    else
    cout<<"NA\n";
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值