VMware Workstation虚拟环境下Linux系统上安装VMware tools工具

版权声明:本文为博主原创文章,遵循 CC 4.0 BY-SA 版权协议,转载请附上原文出处链接和本声明。
本文链接:https://blog.csdn.net/qq_33854781/article/details/81782200

一、开启VMware虚拟机上的Linux操作系统
二、在VMware Workstation上依次点击“虚拟机”—>“安装VMware tools”
三、VMware虚拟机会自动将VMware tools的光盘塞入Linux虚拟机的光驱中。
四、塞入光盘后,Linux操作系统会自动将该光盘挂在到/media目录下,挂在后的路径为:”/media/VMware Tools”。
五、以下操作需要使用Linux操作系统的root用户。
六、将/media/VMware Tools”目录下的“VMwareTools-10.0.10-4301679.tar.gz”文件拷贝至root用户的home目录下“/root”
七、切换路径到/root目录下,并使用”tar -zxvf VMwareTools-10.0.10-4301679.tar.gz”命令解压VMware tools程序包。
八、解压完成后在/root目录下有个“vmware-tools-distrib”的目录。
九、进入“vmware-tools-distrib”目录下,使用“./vmware-install.pl”命令,执行安装。
十、安装过程中,所有选项保持默认即可。
十一、在安装到选择屏幕分辨率时,选择“1024*768”或更大。
十二、安装完成后,重启Linux操作系统即可。

展开阅读全文

关于在VMware安装VMware Tools的问题

11-05

我在VMware5.5.3上安装了Linux红旗6.0rn现在想安装VMware Tolls但是安装时出错 错误代码如下rnStopping VMware Tools services in the virtual machine:rn Guest operating system daemon: [确定]rn Guest filesystem driver: [确定]rnTrying to find a suitable vmhgfs module for your running kernel.rnrnNone of the pre-built vmhgfs modules for VMware Tools is suitable for yourrnrunning kernel. Do you want this program to try to build the vmhgfs module forrnyour system (you need to have a C compiler installed on your system)? [yes]rnrnUsing compiler "/usr/bin/gcc". Use environment variable CC to override.rnrnWhat is the location of the directory of C header files that match your runningrnkernel? [/lib/modules/2.6.22.6-1/build/include]rnrnExtracting the sources of the vmhgfs module.rnrnBuilding the vmhgfs module.rnrnUsing 2.6.x kernel build system.rnmake: Entering directory `/tmp/vmware-config15/vmhgfs-only'rnmake -C /lib/modules/2.6.22.6-1/build/include/.. SUBDIRS=$PWD SRCROOT=$PWD/. modulesrnmake[1]: Entering directory `/usr/src/kernels/2.6.22.6-1-i686'rn CC [M] /tmp/vmware-config15/vmhgfs-only/cpName.orn CC [M] /tmp/vmware-config15/vmhgfs-only/cpNameLinux.orn CC [M] /tmp/vmware-config15/vmhgfs-only/dev.orn CC [M] /tmp/vmware-config15/vmhgfs-only/driver.orn CC [M] /tmp/vmware-config15/vmhgfs-only/hgfsUtil.orn CC [M] /tmp/vmware-config15/vmhgfs-only/main.orn CC [M] /tmp/vmware-config15/vmhgfs-only/staticEscape.orn LD [M] /tmp/vmware-config15/vmhgfs-only/vmhgfs.orn Building modules, stage 2.rn MODPOST 1 modulesrn CC /tmp/vmware-config15/vmhgfs-only/vmhgfs.mod.orn LD [M] /tmp/vmware-config15/vmhgfs-only/vmhgfs.kornmake[1]: Leaving directory `/usr/src/kernels/2.6.22.6-1-i686'rncp -f vmhgfs.ko ./../vmhgfs.ornmake: Leaving directory `/tmp/vmware-config15/vmhgfs-only'rnThe module loads perfectly in the running kernel.rnrnpcnet32 31092 0rnUnloading pcnet32 modulernrnExtracting the sources of the vmxnet module.rnrnBuilding the vmxnet module.rnrnUsing 2.6.x kernel build system.rnmake: Entering directory `/tmp/vmware-config15/vmxnet-only'rnmake -C /lib/modules/2.6.22.6-1/build/include/.. SUBDIRS=$PWD SRCROOT=$PWD/. modulesrnmake[1]: Entering directory `/usr/src/kernels/2.6.22.6-1-i686'rn CC [M] /tmp/vmware-config15/vmxnet-only/vmxnet.orn/tmp/vmware-config15/vmxnet-only/vmxnet.c: In function ‘vmxnet_open’:rn/tmp/vmware-config15/vmxnet-only/vmxnet.c:674: warning: ‘deprecated_irq_flag’ is deprecated (declared at include/linux/interrupt.h:66)rn/tmp/vmware-config15/vmxnet-only/vmxnet.c: In function ‘vmxnet_netpoll’:rn/tmp/vmware-config15/vmxnet-only/vmxnet.c:1058: error: too many arguments to function ‘vmxnet_interrupt’rn[color=#FF0000]make[2]: *** [/tmp/vmware-config15/vmxnet-only/vmxnet.o] 错误 1rnmake[1]: *** [_module_/tmp/vmware-config15/vmxnet-only] 错误 2rnmake[1]: Leaving directory `/usr/src/kernels/2.6.22.6-1-i686'rnmake: *** [vmxnet.ko] 错误 2rnmake: Leaving directory `/tmp/vmware-config15/vmxnet-only'rnUnable to build the vmxnet module.[/color]rnrnThe fast network device driver (vmxnet module) is used only for our fastrnnetworking interface. The rest of the software provided by VMware Tools isrndesigned to work independently of this feature.rnIf you wish to have the fast network driver enabled, you can install the driverrnby running vmware-config-tools.pl again after making sure that gcc, binutils,rnmake and the kernel sources for your running kernel are installed on yourrnmachine. These packages are available on your distribution's installation CD.rn[ Press Enter key to continue ] rnrnrn哪位高手能帮我解决阿rn我的Linux内核版本是2.6.22.6-1 论坛

没有更多推荐了,返回首页