PAT-1118. Birds in Forest (25)

Some scientists took pictures of thousands of birds in a forest. Assume that all the birds appear in the same picture belong to the same tree. You are supposed to help the scientists to count the maximum number of trees in the forest, and for any pair of birds, tell if they are on the same tree.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive number N (<= 104) which is the number of pictures. Then N lines follow, each describes a picture in the format:
K B1 B2 ... BK
where K is the number of birds in this picture, and Bi's are the indices of birds. It is guaranteed that the birds in all the pictures are numbered continuously from 1 to some number that is no more than 104.

After the pictures there is a positive number Q (<= 104) which is the number of queries. Then Q lines follow, each contains the indices of two birds.

Output Specification:

For each test case, first output in a line the maximum possible number of trees and the number of birds. Then for each query, print in a line "Yes" if the two birds belong to the same tree, or "No" if not.

Sample Input:
4
3 10 1 2
2 3 4
4 1 5 7 8
3 9 6 4
2
10 5
3 7
Sample Output:
2 10
Yes

No


题意就是个并查集 就是输入多行数据 表示每行数据的元素是连在一起的 然后再输出连通分支数 和 一共有多少个元素


就是个基本的并查集 - - 但由于开始在find函数里忘写return了 调了好久也没找到。。。wtf

注意题目中鸟的编号未必连续 所以要标记每一个出现过的鸟的编号  然后算鸟的数目 我们可以记录最大编号的鸟 然后遍历检查即可

#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
#include<set>
#include<map>
using namespace std;
int f[10010];
bool book[10010];
bool bok[10010];
int find(int x)
{
	int i=x;
	while(f[i]!=i)
	i=f[i];
	
	int j;
	while(x!=f[x])
	{
		j=f[x];
		f[x]=i;
		x=j;
	}	
	return i; 
}
int main()
{
	int n;
	int M=0,mm=-10010;
	for(int i=1;i<=10000;i++)f[i]=i;
	scanf("%d",&n);
	
	while(n--)
	{
		int m;
		int a,b;
		scanf("%d%d",&m,&a);
		mm=max(a,mm);
		bok[a]=1;
		for(int i=2;i<=m;i++)
		{
			scanf("%d",&b);
			mm=max(b,mm);
			bok[b]=1;
			int ta,tb;
			ta=find(a);
			tb=find(b);	
			if(ta!=tb)f[ta]=tb;
		}
	}
	int sum=0;
	
	for(int i=1;i<=mm;i++)
	{
		if(bok[i])
		{
			M++;	 
			int fa=find(i);
			if(!book[fa])
			{
				book[fa]=1;
				sum++;
			}
		}
//		printf("%d:%d\n",i,f[i]);
	}	
	
	printf("%d %d\n",sum,M);				
		
	int q;
	scanf("%d",&q);
	while(q--)
	{
		int a,b;
		scanf("%d%d",&a,&b);
		if(f[a]==f[b])printf("Yes\n");
		else printf("No\n");
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值