HDU-3697

Selecting courses

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 62768/32768 K (Java/Others)
Total Submission(s): 3138    Accepted Submission(s): 874


Problem Description
    A new Semester is coming and students are troubling for selecting courses. Students select their course on the web course system. There are n courses, the ith course is available during the time interval (A i,B i). That means, if you want to select the ith course, you must select it after time Ai and before time Bi. Ai and Bi are all in minutes. A student can only try to select a course every 5 minutes, but he can start trying at any time, and try as many times as he wants. For example, if you start trying to select courses at 5 minutes 21 seconds, then you can make other tries at 10 minutes 21 seconds, 15 minutes 21 seconds,20 minutes 21 seconds… and so on. A student can’t select more than one course at the same time. It may happen that no course is available when a student is making a try to select a course

You are to find the maximum number of courses that a student can select.

 

Input
There are no more than 100 test cases.

The first line of each test case contains an integer N. N is the number of courses (0<N<=300)

Then N lines follows. Each line contains two integers Ai and Bi (0<=A i<B i<=1000), meaning that the ith course is available during the time interval (Ai,Bi).

The input ends by N = 0.

 

Output
For each test case output a line containing an integer indicating the maximum number of courses that a student can select.
 

Sample Input
  
  
2 1 10 4 5 0
 

Sample Output
  
  
2
 

Source
 

Recommend

chenyongfu



题意:输入若干线段,l r 表示在这两个数之间可以选课 不能在这两个端点的时刻选课,就是在给出的选课线段区间内 在每5分钟选一次课的情况下  求出做大选课数量是多少


贪心+枚举

1000ms ,解决方案是枚举0-4 因为 往后的数都是0-4分别加5的倍数得到的 0-4 分别表示在0.5 1.5 2.5 3.5 4.5 处选课 记为初始值 i

需要先对终点排序 由于 我们要先选早结束的放前面 把晚结束的往后放 这里贪心一下 每次选完标记线段 当前初始值i下 不要再选

我们枚举这5个数 在不断加5加到区间r的最大值 然后对每个数到线段里判断 如果在线段里而不是在端点 就++ 标记线段 下次直接跳过

这里枚举了一下


code:

#include<bits/stdc++.h>

using namespace std;
typedef long long ll;
struct node
{
	int l,r;
}s[310];
bool bok[310]; 
bool cmp(node a,node b)
{
	return a.r<b.r;
}
int main()
{
	int t;
	ios::sync_with_stdio(0);
	
	while(cin>>t,t)
	{
		int m=0,ans = -1;
		for(int i=1;i<=t;i++){
			cin>>s[i].l>>s[i].r;
			m = max(s[i].r,m);	
		}
		sort(s+1,s+1+t,cmp);
		for(int i=0;i<5;i++)
		{//0.5 1.5 2.5 3.5
			int c=0;
			for(int j=1;j<=t;j++)bok[j]=0;	
			for(int k = i;k<m;k+=5) {
			   	for(int p = 1;p<=t;p++){
					if(bok[p])continue;
					else if(k<s[p].r&&k>=s[p].l)//在区间段里 
					{
						c++;
						bok[p]=1;
						break; 
					}
				}	
			} 
			ans = max(ans,c);
		} 
		cout<<ans<<endl;	
	}

	return 0;
} 


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值