PAT(A)-1025 PAT Ranking 模拟|排序|神奇段错误

1025 PAT Ranking (25 分)

Programming Ability Test (PAT) is organized by the College of Computer Science and Technology of Zhejiang University. Each test is supposed to run simultaneously in several places, and the ranklists will be merged immediately after the test. Now it is your job to write a program to correctly merge all the ranklists and generate the final rank.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive number N (≤100), the number of test locations. Then N ranklists follow, each starts with a line containing a positive integer K (≤300), the number of testees, and then K lines containing the registration number (a 13-digit number) and the total score of each testee. All the numbers in a line are separated by a space.

Output Specification:

For each test case, first print in one line the total number of testees. Then print the final ranklist in the following format:

registration_number final_rank location_number local_rank

The locations are numbered from 1 to N. The output must be sorted in nondecreasing order of the final ranks. The testees with the same score must have the same rank, and the output must be sorted in nondecreasing order of their registration numbers.

Sample Input:

2
5
1234567890001 95
1234567890005 100
1234567890003 95
1234567890002 77
1234567890004 85
4
1234567890013 65
1234567890011 25
1234567890014 100
1234567890012 85

Sample Output:

9
1234567890005 1 1 1
1234567890014 1 2 1
1234567890001 3 1 2
1234567890003 3 1 2
1234567890004 5 1 4
1234567890012 5 2 2
1234567890002 7 1 5
1234567890013 8 2 3
1234567890011 9 2 4

 题意不难 就是输入多组数据根据数据排序规则排序 先把每一组的组排序 然后再放到一起写一个汇总排序

注意汇总排序时可以不在结构体里存汇总排序的结果 否则容易超内存 可以直接在输出时根据当前元素的序号和是否跟上个元素的分数相同去输出 如果与上个元素相同就输出上个元素的名词 否则输出当前元素的序号

这种题意简单直观还有没什么算法 只需要模拟实现的问题 注意好实现细节就够了

神奇的是 一开始的代码C读入和C++读入都有 交了一发段错误段错误答案错误...没有一组数据是对的

 

然后鬼使神差地把C式读入全换成c++的后 神奇的全答案正确了。。。

有没有大佬知道这是怎么回事?

ACcode:

#include<cstdio>
#include<cstring>
#include<iostream>
#include<vector>
#include<algorithm>
using namespace std;
typedef long long ll;
struct stu{
    string reg;
    int sc;
    int locNum,locRank;
    stu(){}
    stu(string aa,int b,int c):reg(aa),locNum(b),locRank(c){}
    stu(string aa,int s):reg(aa),sc(s){}
};
stu ans[300010];
int tag;
bool cmp1(stu a,stu b){
    return a.sc>b.sc||(a.sc==b.sc&&a.reg<b.reg);
}
int main(){
    int t;
    ios::sync_with_stdio(0);
    cin.tie(0);
    cout.tie(0);

    cin>>t;
    int flag=0,fr;
    for(int tt=1;tt<=t;tt++){
        int n;
        cin>>n;
        for(int i=1;i<=n;i++){
            string num;
            int sc;
            cin>>num>>sc;
            ans[tag++]=stu(num,sc);
        }
        sort(ans+flag,ans+tag,cmp1);
        ans[flag].locNum = tt;
        ans[flag].locRank = fr = 1;
        for(int i=flag+1;i<tag;i++){
            ans[i].locNum = tt;
            ++fr;
            if(ans[i].sc!=ans[i-1].sc)ans[i].locRank = fr;
            else ans[i].locRank = ans[i-1].locRank;
        }
        flag+=n;
    }
    sort(ans,ans+tag,cmp1);
    cout<<tag<<endl;
    fr = 1;
    cout<<ans[0].reg<<" "<<fr<<" "<<ans[0].locNum<<" "<<ans[0].locRank<<endl;

    for(int i=1;i<tag;i++){
        if(ans[i].sc!=ans[i-1].sc)
            cout<<ans[i].reg<<" "<< (fr = i+1) <<" "<<ans[i].locNum<<" "<<ans[i].locRank<<endl;
        else
            cout<<ans[i].reg<<" "<< fr <<" "<<ans[i].locNum<<" "<<ans[i].locRank<<endl;
    }
    return 0;
}

这个是删除解绑语句 且混用scanf和cin仍旧AC啦~ 应该就是解绑后的scanf和cin以后两者不能混用 混用就会出问题

#include<cstdio>
#include<cstring>
#include<iostream>
#include<vector>
#include<algorithm>
using namespace std;
typedef long long ll;
struct stu{
    string reg;
    int sc;
    int locNum,locRank;
    stu(){}
    stu(string aa,int b,int c):reg(aa),locNum(b),locRank(c){}
    stu(string aa,int s):reg(aa),sc(s){}
};
stu ans[300010];
int tag;
bool cmp1(stu a,stu b){
    return a.sc>b.sc||(a.sc==b.sc&&a.reg<b.reg);
}
int main(){
    int t;

    scanf("%d",&t);
    int flag=0,fr;
    for(int tt=1;tt<=t;tt++){
        int n;
        scanf("%d",&n);
        for(int i=1;i<=n;i++){
            string num;
            int sc;
            cin>>num>>sc;
            ans[tag++]=stu(num,sc);
        }
        sort(ans+flag,ans+tag,cmp1);
        ans[flag].locNum = tt;
        ans[flag].locRank = fr = 1;
        for(int i=flag+1;i<tag;i++){
            ans[i].locNum = tt;
            ++fr;
            if(ans[i].sc!=ans[i-1].sc)ans[i].locRank = fr;
            else ans[i].locRank = ans[i-1].locRank;
        }
        flag+=n;
    }
    sort(ans,ans+tag,cmp1);
    cout<<tag<<endl;
    fr = 1;
    cout<<ans[0].reg<<" "<<fr<<" "<<ans[0].locNum<<" "<<ans[0].locRank<<endl;

    for(int i=1;i<tag;i++){
        if(ans[i].sc!=ans[i-1].sc)
            cout<<ans[i].reg<<" "<< (fr = i+1) <<" "<<ans[i].locNum<<" "<<ans[i].locRank<<endl;
        else
            cout<<ans[i].reg<<" "<< fr <<" "<<ans[i].locNum<<" "<<ans[i].locRank<<endl;
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值