pengpengsays

互联网技术分享

Gradle打包问题Deprecated Gradle features were used in this build, making it incompatible with Gradle 5.0

前言

使用gradle打包react native的时候,出现了如下报错,下面和大家说一下解决的具体办法

Deprecated Gradle features were used in this build, making it incompatible with Gradle 5.0

问题详解

从字面意思来看,是因为当前项目使用了gradle版本过渡时候的语法和特性,而本地环境的gradle版本太高,不支持之前的语法和特性,所以导致报错。

问题解决

其实这个问题还是比较好解决的,最简单的方法也是最推荐的方法是使用项目下自带的gradle.bat(windows平台)或gradle(linux平台)来运行项目,因为项目自带的是和当前项目版本最符合的。进入android目录,运行:

gradle.bat assembleRelease      --Windows

或者

./gradle assembleRelease        --Linux,Macd

当然,最麻烦的方法就是将本地环境的gradle版本退回与项目相符合的版本。


阅读更多
想对作者说点什么? 我来说一句

没有更多推荐了,返回首页

不良信息举报

Gradle打包问题Deprecated Gradle features were used in this build, making it incompatible with Gradle 5.0

最多只允许输入30个字

加入CSDN,享受更精准的内容推荐,与500万程序员共同成长!
关闭
关闭