HDU - 6805 D - Deliver the Cake

本文介绍了一个有趣的算法问题:如何在有限时间内,通过切换手部携带方式,将生日蛋糕从烤箱送到家。涉及到村庄、道路、左右手切换时间和特殊村庄规则,通过构建图形并使用Dijkstra算法找到最短路径。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

It is Zhang3's birthday! Zhang3 has bought a birthday cake and now it's time to take it home. 

There are nn villages, labeled 1,2,…,n1,2,…,n. There are mm bidirectional roads, the ithith of which connects village aiai, bibi and it is didi meter(s) long. 

The bakery locates at village ss and Zhang3's home locates at village tt. So Zhang3 wants to carry the cake from ss to tt. She can carry the cake either with her left hand or with her right hand. She can switch to the other hand during the trip, which takes extra xx second(s) each time (when she's performing this action, she must stay in her place). Switching is allowed at any place, including the middle of the roads. She can do this as many times as she like, or don't do it at all. 

Some villages are LEFT. When Zhang3 is at a LEFT village, she must carry the cake with her left hand at the moment. In the same way, some other villages are RIGHT, she must carry with her right hand when she's at these villages. The rest villages are called MIDDLE. There's no special rules at MIDDLE villages. 

Zhang3 can start and finish with any hand carrying the cake. However, if ss or tt is not MIDDLE, their special rules must be followed. 

Please help Zhang3 find a way to take the cake home, with the minimum amount of spent time. 

Input

The first line of the input gives the number of test cases, T(1≤T≤100)T(1≤T≤100). TT test cases follow. 

For each test case, the first line contains five integers n,m,s,t,x(1≤n≤105,1≤m≤2×105,1≤x≤109)n,m,s,t,x(1≤n≤105,1≤m≤2×105,1≤x≤109), representing the number of villages, the number of roads, the bakery's location, home's location, and the time spent for each switching. 

The next line contains a string of length nn, describing the type of each village. The ithith character is either LL representing village ii is LEFT, or MM representing MIDDLE, or RR representing RIGHT. 

Finally, mm lines follow, the ithith of which contains three integers ai,bi,di(1≤di≤109)ai,bi,di(1≤di≤109), denoting a road connecting village aiai and bibi of length didi. 

It is guaranteed that tt can be reached from ss. 

The sum of nn in all test cases doesn't exceed 2×1052×105. The sum of mm doesn't exceed 4×1054×105. 

Output

For each test case, print a line with an integer, representing the minimum amount of spent time (in seconds). 

Sample Input

1
3 3 1 3 100
LRM
1 2 10
2 3 10
1 3 100

Sample Output

100

Sponsor

拆点建图

一开始习惯性敲spfa。。。

然后t了好久

dij秒过 记得开longlong

#include<bits/stdc++.h>
#define ll long long
using namespace std;
const int maxn = 2e6 + 5;
int head[maxn];
int vis[maxn];
ll dis[maxn];
int tot;
int T, S;
int n, m;
ll vl;
char val[maxn];
struct node{
    int to;
    int next;
    ll v;
    node() {}
    node(int a, int b, ll c) : to(a), next(b), v(c) {}
} edge[maxn];
 
void edgeadd(int s, int e, ll v){
    edge[tot] = node(e, head[s], v);
    head[s] = tot++;
    edge[tot] = node(s, head[e], v);
    head[e] = tot++;
}
 
void init(){
    memset(head, -1, sizeof(head));
    tot = 0;
}
 
struct  Node{
    int num;
    ll c;
    Node() {}
    Node(int a, ll b) : num(a), c(b) {}
    bool operator < (const Node &rsh)const{
        return c > rsh.c;
    }
};
 
void dijstra(int str){
	memset(vis, 0, sizeof(vis));
    memset(dis, 0x3f3f3f3f3f3f3f3f, sizeof(dis));
    priority_queue<Node> q;
    while(!q.empty()){
        q.pop();
    }
    q.push(Node(str, 0));
    dis[str] = 0;
    Node p;
    while(!q.empty()){
        p = q.top();
        q.pop();
        int u = p.num;
        if(vis[u]) continue;
        vis[u] = 1;
        for(int i = head[u]; i != -1; i = edge[i].next){
            int v = edge[i].to;
            ll val = edge[i].v;
            if(!vis[v] && dis[v] > dis[u] + val){
                dis[v] = dis[u] + val;
                q.push(Node(v, dis[v]));
            }
        }
    }
}

int main(){
	ios::sync_with_stdio(false);
	int t;
	cin >> t;
	while(t--){
		init();
		cin >> n >> m >> S >> T >> vl;
		for(int i = 1; i <= n; i++)
			cin >> val[i];
		for(int i = 1; i <= m; i++){
			int a, b;
			ll vv;
			cin >> a >> b >> vv;
			if(val[a] != 'M' && val[b] != 'M'){
				if(val[a] == val[b]){
					edgeadd(a, b, vv);
				}
				else{
					edgeadd(a, b, vv + vl);
				}
			}
			else{
				if(val[a] != 'M' && val[b] == 'M'){
					if(val[a] == 'R'){
						edgeadd(a, b, vv);
						edgeadd(a, b + n, vv + vl);
					}
					else{
						edgeadd(a, b + n, vv);
						edgeadd(a, b, vv + vl);
					
					}
				}
				if(val[a] == 'M' && val[b] != 'M'){
					if(val[b] == 'R'){
						edgeadd(a, b, vv);
						edgeadd(a + n, b, vv + vl);
					}
					else{
						edgeadd(a + n, b, vv);
						edgeadd(a, b, vv + vl);
					}
				}
				if(val[a] == 'M' && val[b] == 'M'){
					edgeadd(a, b, vv);
					edgeadd(a + n, b + n, vv);
					edgeadd(a + n, b, vv + vl);
					edgeadd(a, b + n, vv + vl);
				} 
			}
		}
		ll ans;
		if(val[S] == 'M' && val[T] == 'M'){
			dijstra(S);
			ans = min(dis[T], dis[T + n]);
			dijstra(S + n);
			ans = min(ans, min(dis[T], dis[T + n]));
		}
		if(val[S] != 'M' && val[T] == 'M'){
			dijstra(S);
			ans = min(dis[T], dis[T + n]);
		}
		if(val[S] == 'M' && val[T] != 'M'){
			dijstra(S);
			ans = dis[T];
			dijstra(S + n);
			ans = min(ans, dis[T]);
		}
		if(val[S] != 'M' && val[T] != 'M'){
			dijstra(S);
			ans = dis[T];
		}
		cout << ans << endl;
	}
}

 

内容概要:本文详细介绍了基于结构不变补偿的电液伺服系统低阶线性主动干扰抑制控制(ADRC)方法的实现过程。首先定义了电液伺服系统的基本参数,并实现了结构不变补偿(SIC)函数,通过补偿非线性项和干扰,将原始系统转化为一阶积分链结构。接着,设计了低阶线性ADRC控制器,包含扩展状态观测器(ESO)和控制律,用于估计系统状态和总干扰,并实现简单有效的控制。文章还展示了系统仿真与对比实验,对比了低阶ADRC与传统PID控制器的性能,证明了ADRC在处理系统非线性和外部干扰方面的优越性。此外,文章深入分析了参数调整与稳定性,提出了频域稳定性分析和b0参数调整方法,确保系统在参数不确定性下的鲁棒稳定性。最后,文章通过综合实验验证了该方法的有效性,并提供了参数敏感性分析和工程实用性指导。 适合人群:具备一定自动化控制基础,特别是对电液伺服系统和主动干扰抑制控制感兴趣的科研人员和工程师。 使用场景及目标:①理解电液伺服系统的建模与控制方法;②掌握低阶线性ADRC的设计原理和实现步骤;③学习如何通过结构不变补偿简化复杂系统的控制设计;④进行系统仿真与实验验证,评估不同控制方法的性能;⑤掌握参数调整与稳定性分析技巧,确保控制系统在实际应用中的可靠性和鲁棒性。 阅读建议:本文内容详尽,涉及多个控制理论和技术细节。读者应首先理解电液伺服系统的基本原理和ADRC的核心思想,然后逐步深入学习SIC补偿、ESO设计、控制律实现等内容。同时,结合提供的代码示例进行实践操作,通过调整参数和运行仿真,加深对理论的理解。对于希望进一步探索的读者,可以关注文中提到的高级话题,如频域稳定性分析、参数敏感性分析等,以提升对系统的全面掌控能力。
### 关于HDU - 6609 的题目解析 由于当前未提供具体关于 HDU - 6609 题目的详细描述,以下是基于一般算法竞赛题型可能涉及的内容进行推测和解答。 #### 可能的题目背景 假设该题目属于动态规划类问题(类似于多重背包问题),其核心在于优化资源分配或路径选择。此类问题通常会给出一组物品及其属性(如重量、价值等)以及约束条件(如容量限制)。目标是最优地选取某些物品使得满足特定的目标函数[^2]。 #### 动态转移方程设计 如果此题确实是一个变种的背包问题,则可以采用如下状态定义方法: 设 `dp[i][j]` 表示前 i 种物品,在某种条件下达到 j 值时的最大收益或者最小代价。对于每一种新加入考虑范围内的物体 k ,更新规则可能是这样的形式: ```python for i in range(n): for s in range(V, w[k]-1, -1): dp[s] = max(dp[s], dp[s-w[k]] + v[k]) ``` 这里需要注意边界情况处理以及初始化设置合理值来保证计算准确性。 另外还有一种可能性就是它涉及到组合数学方面知识或者是图论最短路等相关知识点。如果是后者的话那么就需要构建相应的邻接表表示图形结构并通过Dijkstra/Bellman-Ford/Floyd-Warshall等经典算法求解两点间距离等问题了[^4]。 最后按照输出格式要求打印结果字符串"Case #X: Y"[^3]。 #### 示例代码片段 下面展示了一个简单的伪代码框架用于解决上述提到类型的DP问题: ```python def solve(): t=int(input()) res=[] cas=1 while(t>0): n,k=list(map(int,input().split())) # Initialize your data structures here ans=find_min_unhappiness() # Implement function find_min_unhappiness() res.append(f'Case #{cas}: {round(ans)}') cas+=1 t-=1 print("\n".join(res)) solve() ```
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值