HUD-2141 变种二分枚举 binary_search函数初始用

 

Can you find it?

 HDU - 2141 

Give you three sequences of numbers A, B, C, then we give you a number X. Now you need to calculate if you can find the three numbers Ai, Bj, Ck, which satisfy the formula Ai+Bj+Ck = X. 

Input

There are many cases. Every data case is described as followed: In the first line there are three integers L, N, M, in the second line there are L integers represent the sequence A, in the third line there are N integers represent the sequences B, in the forth line there are M integers represent the sequence C. In the fifth line there is an integer S represents there are S integers X to be calculated. 1<=L, N, M<=500, 1<=S<=1000. all the integers are 32-integers. 

Output

For each case, firstly you have to print the case number as the form "Case d:", then for the S queries, you calculate if the formula can be satisfied or not. If satisfied, you print "YES", otherwise print "NO". 

Sample Input

3 3 3
1 2 3
1 2 3
1 2 3
3
1
4
10

Sample Output

Case 1:
NO
YES
NO

这题其实是一个变种的二分 

这里介绍一下binary_search函数 如果找到返回1 没找到返回0

先枚举a + b的情况 然后 用输入值减去sum的值去进行二分查找c 即可ac

如果反过来枚举 会Runtime Error(ACCESS_VIOLATION)

因为两个数组大小不同

#include<bits/stdc++.h>
using namespace std;
const int maxn = 5e2 + 5;
int L, N, M;
int K;
int a[maxn];
int b[maxn];
int c[maxn];
int sum[maxn * maxn];
int d = 0;
int main(){
	while(~scanf("%d%d%d",&L, &N, &M)){
		d++;
		cout << "Case " << d << ":" << endl;
		for(int i = 0; i < L; i++)
			cin >> a[i];
		int k = 0;
		for(int i = 0; i < N; i++){
			cin >> b[i];
			for(int j = 0; j < L; j++){
				sum[k++] = b[i] + a[j]; 
			}
		}
		sort(sum, sum + k);
		for(int i = 0; i < M; i++)
			cin >> c[i];
		
		cin >> K;
		int v;
		
		for(int i = 1; i <= K; i++){
			cin >> v;
			int flag = 0;
			for(int j = 0; j < M; j++){
				if(binary_search(sum, sum + k, v - c[j]) == 1){
					flag = 1;
					break;
				}		
			}
			if(flag == 1)
				cout << "YES" << endl;
			else
				cout << "NO" << endl;	
		}	
		
	}
}

 

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值