HDU A + B Problem II

题目链接

I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.

Output
For each test case, you should output two lines. The first line is “Case #:”, # means the number of the test case. The second line is the an equation “A + B = Sum”, Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.

Sample Input
2
1 2
112233445566778899 998877665544332211

Sample Output
Case 1:
1 + 2 = 3

Case 2:
112233445566778899 + 998877665544332211 = 1111111111111111110

#include <bits/stdc++.h>
using namespace std;
int main()
{
    int i,j,k,t,l,len1,len2,flag=1;
    int a1[1005],b1[1005],c[1005];
    char a[1005],b[1005];
    scanf("%d",&t);
    for(j=1; j<=t; j++)
    {
        scanf("%s %s",a,b);
        if(flag==0)
            printf("\n");
        len1=strlen(a);
        len2=strlen(b);
        printf("Case %d:\n",j);
        memset(a1,0,sizeof(a1));
        memset(b1,0,sizeof(b1));
        memset(c,0,sizeof(c));
        k=0;
        for(i=len1-1; i>=0; i--)
        {
            int sun=a[i];
            a1[k++]=sun-48;
        }
        k=0;
        for(i=len2-1; i>=0; i--)
        {
            int sun=b[i];
            b1[k++]=sun-48;
        }
        l=max(len1,len2);
        for(i=0; i<l; i++)
            if(a1[i]+b1[i]+c[i]>9)
            {
                c[i]=(a1[i]+b1[i]+c[i])%10;
                c[i+1]++;
            }
            else
                c[i]=a1[i]+b1[i]+c[i];
        printf("%s + %s = ",a,b);
        if(c[l]==0)
        {
            for(i=l-1; i>=0; i--)
                printf("%d",c[i]);
            printf("\n");
        }
        if(c[l]!=0)
        {
            for(i=l; i>=0; i--)
                printf("%d",c[i]);
            printf("\n");
        }
        flag=0;
    }
    return 0;
}

java代码,大数模拟,直接用BigInteger,比c++的字符串模拟快多了,记录一下
注:代码是在杭电的oj交的

import java.util.*;
import java.math.*;
public class Main
{
    public static void main(String [] args)
    {
        int t,j;
        Scanner cin = new Scanner(System.in);
        BigInteger a,b;
        t=cin.nextInt();
        for(j=1; j<=t; j++)
        {
            a=cin.nextBigInteger();
            b=cin.nextBigInteger();
            System.out.println("Case "+j+":");
            System.out.print(a+" + "+b+" = ");
            System.out.println(a.add(b));
            if(j!=t)
                System.out.println();
        }
    }
}

下面是大数的一些运算方法;

import java.util.;
import java.math.
;
public class Main{
public static void main(String args[]){
Scanner cin = new Scanner(System.in);
BigInteger a, b;
//以文件EOF结束
while (cin.hasNext()){
a = cin.nextBigInteger();
b = cin.nextBigInteger();
System.out.println(a.add(b)); //大整数加法
System.out.println(a.subtract(b)); //大整数减法
System.out.println(a.multiply(b)); //大整数乘法
System.out.println(a.divide(b)); //大整数除法(取整)
System.out.println(a.remainder(b)); //大整数取模
//大整数的比较
if( a.compareTo(b) == 0 ) System.out.println(“a == b”); //大整数a==b
else if( a.compareTo(b) > 0 ) System.out.println(“a > b”); //大整数a>b
else if( a.compareTo(b) < 0 ) System.out.println(“a < b”); //大整数a<b
//大整数绝对值
System.out.println(a.abs()); //大整数a的绝对值
//大整数的幂
int exponent=10;
System.out.println(a.pow(exponent)); //大整数a的exponent次幂
//返回大整数十进制的字符串表示
System.out.println(a.toString());
//返回大整数p进制的字符串表示
int p=8;
System.out.println(a.toString§);
}
}
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值