木块问题(vector)-UVa 101

The Blocks Problem

Time Limit: 1000ms
Memory Limit: 10000KB
This problem will be judged on  PKU. Original ID:  1208
64-bit integer IO format:  %lld      Java class name:  Main

Many areas of Computer Science use simple, abstract domains for both analytical and empirical studies. For example, an early AI study of planning and robotics (STRIPS) used a block world in which a robot arm performed tasks involving the manipulation of blocks. 
In this problem you will model a simple block world under certain rules and constraints. Rather than determine how to achieve a specified state, you will "program" a robotic arm to respond to a limited set of commands. 
The problem is to parse a series of commands that instruct a robot arm in how to manipulate blocks that lie on a flat table. Initially there are n blocks on the table (numbered from 0 to n-1) with block bi adjacent to block bi+1 for all 0 <= i < n-1 as shown in the diagram below: 

The valid commands for the robot arm that manipulates blocks are: 

move a onto b 
where a and b are block numbers, puts block a onto block b after returning any blocks that are stacked on top of blocks a and b to their initial positions. 


move a over b 
where a and b are block numbers, puts block a onto the top of the stack containing block b, after returning any blocks that are stacked on top of block a to their initial positions. 


pile a onto b 
where a and b are block numbers, moves the pile of blocks consisting of block a, and any blocks that are stacked above block a, onto block b. All blocks on top of block b are moved to their initial positions prior to the pile taking place. The blocks stacked above block a retain their order when moved. 


pile a over b 
where a and b are block numbers, puts the pile of blocks consisting of block a, and any blocks that are stacked above block a, onto the top of the stack containing block b. The blocks stacked above block a retain their original order when moved. 


quit 
terminates manipulations in the block world. 

Any command in which a = b or in which a and b are in the same stack of blocks is an illegal command. All illegal commands should be ignored and should have no affect on the configuration of blocks. 

Input

The input begins with an integer n on a line by itself representing the number of blocks in the block world. You may assume that 0 < n < 25. 
The number of blocks is followed by a sequence of block commands, one command per line. Your program should process all commands until the quit command is encountered. 

You may assume that all commands will be of the form specified above. There will be no syntactically incorrect commands.

Output

The output should consist of the final state of the blocks world. Each original block position numbered i ( 0 <= i < n where n is the number of blocks) should appear followed immediately by a colon. If there is at least a block on it, the colon must be followed by one space, followed by a list of blocks that appear stacked in that position with each block number separated from other block numbers by a space. Don't put any trailing spaces on a line. 

There should be one line of output for each block position (i.e., n lines of output where n is the integer on the first line of input). 

Sample Input

10
move 9 onto 1
move 8 over 1
move 7 over 1
move 6 over 1
pile 8 over 6
pile 8 over 5
move 2 over 1
move 4 over 9
quit

Sample Output

0: 0
1: 1 9 2 4
2:
3: 3
4:
5: 5 8 7 6
6:
7:
8:

9:

#include<cstdio>
#include<string>
#include<vector>
#include<iostream>
using namespace std;

const int maxn=30;
int n;
vector<int> pile[maxn];
int x[maxn];
int y[maxn];
vector<int> dui;

void print()
{
	for(int i=0;i<n;i++)
	{
		for(int j=0;j<pile[i].size();j++)
		printf("%4d",pile[i][j]);
		printf("\n");
	}
	printf("\n");
}

void back_pos(int d)	 //此木块以上的木块全部归位 
{
	int x0=x[d],y0=y[d];
	int l=pile[x0].size();
	for(int i=y0+1;i<l;i++)
	{
		int d1=pile[x0].back();
		x[d1]=d1;
		y[d1]=pile[d1].size();
		pile[d1].push_back(d1);
		pile[x0].pop_back();
	}
}

void pile_onto(int d,int dstx)		//将此木块及其以上的木块整体移动到目标堆上去 
{
	int x0=x[d],y0=y[d];
	int l=pile[x0].size();
	for(int i=y0;i<l;i++)
	{
		dui.push_back(pile[x0].back());
		pile[x0].pop_back();
	}
	for(int i=y0;i<l;i++)
	{
		x[dui.back()]=dstx;
		y[dui.back()]=pile[dstx].size();
		pile[dstx].push_back(dui.back());
		dui.pop_back();
		
	}
}

int main()
{
	
	int a,b;
	string s1,s2;
	scanf("%d",&n);
	for(int i=0;i<n;i++)
	{
		pile[i].push_back(i);
		x[i]=i;
		y[i]=0; 
	}
	print();
	
	while(1)
	{
		cin>>s1;
		if(s1=="quit") break;
		cin>>a>>s2>>b;
		if(x[a]==x[b]) continue;    //非法 
		if(s1=="move") back_pos(a);
		if(s2=="onto") back_pos(b);
		pile_onto(a,x[b]);
		print();
		
		 
	}
	print();
	
	return 0;
	
	
}
一共有四个指令,每个指令里有相同的操作,把相同的操作提取出来,写成
void back_pos(int d)和<span style="font-family: Menlo, Monaco, Consolas, 'Courier New', monospace; white-space: pre-wrap;">void pile_onto(int d,int dstx)	</span>
<span style="font-family: Menlo, Monaco, Consolas, 'Courier New', monospace; white-space: pre-wrap;">这样简化了代码</span>

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值