【HDOJ】6213--Chinese Zodiac

Problem Description

The Chinese Zodiac, known as Sheng Xiao, is based on a twelve-year cycle, each year in the cycle related to an animal sign. These signs are the rat, ox, tiger, rabbit, dragon, snake, horse, sheep, monkey, rooster, dog and pig.
Victoria is married to a younger man, but no one knows the real age difference between the couple. The good news is that she told us their Chinese Zodiac signs. Their years of birth in luner calendar is not the same. Here we can guess a very rough estimate of the minimum age difference between them.
If, for instance, the signs of Victoria and her husband are ox and rabbit respectively, the estimate should be 2 years. But if the signs of the couple is the same, the answer should be 12 years.

Input

The first line of input contains an integer T (1≤T≤1000) indicating the number of test cases.
For each test case a line of two strings describes the signs of Victoria and her husband.

Output

For each test case output an integer in a line.

Sample Input

3
ox rooster
rooster ox
dragon dragon

Sample Output

8
4
12

Source

2017 ACM/ICPC Asia Regional Qingdao Online

Recommend

liuyiding


代码
#include <iostream>
using namespace std;

int cvt(string n){
    if(n == "rat"){
        return 1;
    }
    else if(n == "ox"){
        return 2;
    }
    else if(n == "tiger"){
        return 3;
    }
    else if(n == "rabbit"){
        return 4;
    }
    else if(n == "dragon"){
        return 5;
    }
    else if(n == "snake"){
        return 6;
    }
    else if(n == "horse"){
        return 7;
    }
    else if(n == "sheep"){
        return 8;
    }
    else if(n == "monkey"){
        return 9;
    }
    else if(n == "rooster"){
        return 10;
    }
    else if(n == "dog"){
        return 11;
    }
    else if(n == "pig"){
        return 12;
    }
}

int main(){
    int i, t, num1, num2, res;
    string inp1, inp2;
    cin >> t;
    cin.ignore(1);
    for(i = 1; i <= t; ++i){
        cin >> inp1 >> inp2;
        num1 = cvt(inp1);
        num2 = cvt(inp2);
        if(num2 > num1){
            res = num2 - num1;
        }
        else if(num2 < num1){
            res = 12 + num2 - num1;
        }
        else{
            res = 12;
        }
        cout << res << endl;
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值