POJ3122

Pie
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 15270 Accepted: 5226 Special Judge

Description

My birthday is coming up and traditionally I'm serving pie. Not just one pie, no, I have a number N of them, of various tastes and of various sizes. F of my friends are coming to my party and each of them gets a piece of pie. This should be one piece of one pie, not several small pieces since that looks messy. This piece can be one whole pie though.

My friends are very annoying and if one of them gets a bigger piece than the others, they start complaining. Therefore all of them should get equally sized (but not necessarily equally shaped) pieces, even if this leads to some pie getting spoiled (which is better than spoiling the party). Of course, I want a piece of pie for myself too, and that piece should also be of the same size.

What is the largest possible piece size all of us can get? All the pies are cylindrical in shape and they all have the same height 1, but the radii of the pies can be different.

Input

One line with a positive integer: the number of test cases. Then for each test case:
  • One line with two integers N and F with 1 ≤ N, F ≤ 10 000: the number of pies and the number of friends.
  • One line with N integers ri with 1 ≤ ri ≤ 10 000: the radii of the pies.

Output

For each test case, output one line with the largest possible volume V such that me and my friends can all get a pie piece of size V. The answer should be given as a floating point number with an absolute error of at most 10 −3.

Sample Input

3
3 3
4 3 3
1 24
5
10 5
1 4 2 3 4 5 6 5 4 2

Sample Output

25.1327
3.1416
50.2655

Source

Northwestern Europe 2006

第一行输入的值是有T组测试数据;
第二行是n块派,小主人有f个朋友,
第三行是每块派的的半径。
题意就是朋友加上小主人自己每个人必须并且只能分到一块派,每个人的大小都要相同,要输出每个人可以得到的最大的派的面积。

这道题的解决思想就是二分加贪心,要注意的就是精度问题。

以下是AC代码:
#include <iostream>
#include <cstdio>
#include <cmath>
#include <algorithm>
#include <cstring>

using namespace std;

const double PI = acos(-1.0);//∏的值,不能写成3.1415926,否则会精度缺失
double a[10005];
int n,f;

bool cmp(double a,double b){
    return a > b;
}

int check(double mid){
    int sum = 0;
    for(int i = 0;i < n;i++){
        sum += (int)(a[i]/mid);//记录此次能分到多少个人
        if(sum >= f)
            return 1;
    }
    return 0;
}

int main()
{
    int T;
    scanf("%d",&T);
    while(T--){
        memset(a,0,sizeof(a));
        double l = 0,r = 0,mid = 0;
        scanf("%d %d",&n,&f);
        f = f+1;//加上小主人自己
        for(int i = 0;i < n;i++){
            scanf("%lf",&a[i]);
            a[i] = a[i] * a[i];
        }
        sort(a,a+n,cmp);
        l = 0;
        r = a[0];
        if(f < n)
            n = f;//如果派比人多的话,只取数组前f个
        while(r-l > 1e-7)//达到精度停止二分
        {
            mid = (l+r)/2;
            if(check(mid))
                l = mid;//如果每人可以分到,将l置为mid,因为此时要考虑能不能有更大的分法
            else
                r = mid;//如果不够分,将r置为mid
        }
        printf("%.4lf\n",l*PI);//PI一定要最后再乘,否则会精度缺失,最后mid和l值相等的,所以之力用l和mid都可以
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值