[传递闭包]POJ#3660 Cow Contest

题面

传送门
Cow Contest
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 24342 Accepted: 13539
Description

N (1 ≤ N ≤ 100) cows, conveniently numbered 1…N, are participating in a programming contest. As we all know, some cows code better than others. Each cow has a certain constant skill rating that is unique among the competitors.

The contest is conducted in several head-to-head rounds, each between two cows. If cow A has a greater skill level than cow B (1 ≤ A ≤ N; 1 ≤ B ≤ N; A ≠ B), then cow A will always beat cow B.

Farmer John is trying to rank the cows by skill level. Given a list the results of M (1 ≤ M ≤ 4,500) two-cow rounds, determine the number of cows whose ranks can be precisely determined from the results. It is guaranteed that the results of the rounds will not be contradictory.

Input

  • Line 1: Two space-separated integers: N and M
  • Lines 2…M+1: Each line contains two space-separated integers that describe the competitors and results (the first integer, A, is the winner) of a single round of competition: A and B

Output

  • Line 1: A single integer representing the number of cows whose ranks can be determined

Sample Input

5 5
4 3
4 2
3 2
1 2
2 5

Sample Output

2

题目大意

能知道哪些牛比哪些牛强,问可以确定排名的牛有多少。

解题思路

能确定排名,那么这头牛与其他牛的关系得是确定的,就利用形似floyd算法的方式找传递闭包。

AC代码

#include<cstdlib>
#include<cstring>
#include<cstdio>
using namespace std;

const int maxn = 101;
bool f[maxn][maxn];
int n, m, ans = 0;

void floyd(void){
    for(int k = 1; k <=n ; k++)
        for(int i = 1; i <=n ; i++)
            for(int j = 1; j <= n; j++)
                f[i][j]=(f[i][k]&&f[k][j]) ? 1 : f[i][j];
}

int main(){
    memset(f,0,sizeof(f));
    scanf("%d%d", &n,&m);
    for(int i = 1, u, v; i <= m; i++){
        scanf("%d%d",&u,&v);
        f[u][v]=1;
    }
    floyd();
    for(int i = 1,cnt;  i <= n; i++){
        cnt = 0;
        for(int j = 1; j <= n; j++){
            cnt+=f[i][j]||f[j][i];
        }
        if(cnt == n-1)ans++;
    }
    printf("%d\n",ans);
    // system("pause");
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

McDuck_Spirit

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值