C - Can you solve this equation? HDU - 2199(二分水题)

Now,given the equation 8x^4 + 7x^3 + 2x^2 + 3x + 6 == Y,can you
find its solution between 0 and 100; Now please try your lucky. Input
The first line of the input contains an integer T(1<=T<=100) which
means the number of test cases. Then T lines follow, each line has a
real number Y (fabs(Y) <= 1e10); Output For each test case, you should
just output one real number(accurate up to 4 decimal places),which is
the solution of the equation,or “No solution!”,if there is no solution
for the equation between 0 and 100. Sample Input

2
100
-4
Sample Output
1.6152
No solution!
#include<iostream>
#include<algorithm>
#include<cstdio>
#include<cmath>
using namespace std;

#define ll long long  
#define db double
const int Len = 1e5+10;

db Cal(db m)
{
    return 8 * pow(m, 4) + 7 * pow(m, 3) + 2 * pow(m, 2) + 3 * m + 6;
}


int main()
{
    //freopen("A.txt","r",stdin);
    int t;
    cin >> t;
    while(t --)
    {
        int n;
        scanf("%d", &n);
        db l = 0, r = 100;
        if(Cal(0) > n || Cal(100) < n)
            cout << "No solution!\n";
        else
        {
            db m;
            while(r - l >= 1e-10)
            {
                m = (l + r)/2;
                if(Cal(m) > n)
                    r = m;
                else
                    l = m;
            }
            printf("%.4lf\n", m);
        }
    }


    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值