记忆化搜索简介

<span style="font-family: Arial, Helvetica, sans-serif; background-color: rgb(255, 255, 255);">在dp的方面,记忆化搜索感觉不如递推好用,这是肯定的,但有些时候dp的转移过程过于复杂很难求解一个问题的时候其子问题都解决了,所以这个时候可以用记忆化搜索来解决</span>

记忆化搜索因为可以将已经求解的问题保存起来,所以求解非常快,这个方法的基本思想就是由下到上求解,先递归到最底层,然后层层向上去解决这个问题,在这中间会有重叠子问题,大大加快了求解过程,可以用memset 将dp的值全部设置为-1 表示不知道值的子问题 dp[x][y]>=0表示在x y点的最优解已经求解出来了。

例题 hdu1078

FatMouse and Cheese
Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 5128    Accepted Submission(s): 2078


Problem Description
FatMouse has stored some cheese in a city. The city can be considered as a square grid of dimension n: each grid location is labelled (p,q) where 0 <= p < n and 0 <= q < n. At each grid location Fatmouse has hid between 0 and 100 blocks of cheese in a hole. Now he‘s going to enjoy his favorite food.

FatMouse begins by standing at location (0,0). He eats up the cheese where he stands and then runs either horizontally or vertically to another location. The problem is that there is a super Cat named Top Killer sitting near his hole, so each time he can run at most k locations to get into the hole before being caught by Top Killer. What is worse -- after eating up the cheese at one location, FatMouse gets fatter. So in order to gain enough energy for his next run, he has to run to a location which have more blocks of cheese than those that were at the current hole.

Given n, k, and the number of blocks of cheese at each grid location, compute the maximum amount of cheese FatMouse can eat before being unable to move. 
 

Input
There are several test cases. Each test case consists of 

a line containing two integers between 1 and 100: n and k 
n lines, each with n numbers: the first line contains the number of blocks of cheese at locations (0,0) (0,1) ... (0,n-1); the next line contains the number of blocks of cheese at locations (1,0), (1,1), ... (1,n-1), and so on. 
The input ends with a pair of -1‘s. 
 

Output
For each test case output in a line the single integer giving the number of blocks of cheese collected. 
 

Sample Input
   
   
3 1 1 2 5 10 11 6 12 12 7 -1 -1
 

Sample Output
   
   
37

#include <stdio.h>
#include <stdlib.h>
#include <string>
#include <iostream>
#include <algorithm>
#include <ctype.h>
#include <map>
#include <set>
#include <sstream>
#include <ostream>
using namespace std;
int mat[105][105];
int dp[105][105];
int dx[4]={1,-1,0,0};
int dy[4]={0,0,1,-1};
int n,k;
int check(int x,int y)
{
    if(x<n&&x>=0&&y<n&&y>=0) return 1;
    return 0;
}
int search(int x,int y){
    if(dp[x][y]>=0) return dp[x][y];
    else{
        int maxx=0;
        int mark=0;
        for(int c=1;c<=k;c++)
        {
            for(int i=0;i<4;i++)
            {
                if(check(x+c*dx[i],y+c*dy[i])&&mat[x][y]<mat[x+c*dx[i]][y+c*dy[i]])
                {
                    mark=1;
                    int save=search(x+c*dx[i],y+c*dy[i]);
                    if(save>maxx) maxx=save;
                }
            }
        }
        if(mark==0)
              dp[x][y]=mat[x][y];
        else
              dp[x][y]=maxx+mat[x][y];
    }
    return dp[x][y];
}
int main()
{
    while(cin>>n>>k){
        if(n==-1&&k==-1) return 0;
    memset(dp,-1,sizeof(dp));
    for(int i=0;i<n;i++)
    {
        for(int j=0;j<n;j++)
            cin>>mat[i][j];
    }
    search(0,0);
    cout<<dp[0][0]<<endl;
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值