POJ 2377 Bad Cowtractors (最大生成树)

题目链接:http://poj.org/problem?id=2377


Bad Cowtractors
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 13474 Accepted: 5570

Description

Bessie has been hired to build a cheap internet network among Farmer John's N (2 <= N <= 1,000) barns that are conveniently numbered 1..N. FJ has already done some surveying, and found M (1 <= M <= 20,000) possible connection routes between pairs of barns. Each possible connection route has an associated cost C (1 <= C <= 100,000). Farmer John wants to spend the least amount on connecting the network; he doesn't even want to pay Bessie. 

Realizing Farmer John will not pay her, Bessie decides to do the worst job possible. She must decide on a set of connections to install so that (i) the total cost of these connections is as large as possible, (ii) all the barns are connected together (so that it is possible to reach any barn from any other barn via a path of installed connections), and (iii) so that there are no cycles among the connections (which Farmer John would easily be able to detect). Conditions (ii) and (iii) ensure that the final set of connections will look like a "tree".

Input

* Line 1: Two space-separated integers: N and M 

* Lines 2..M+1: Each line contains three space-separated integers A, B, and C that describe a connection route between barns A and B of cost C.

Output

* Line 1: A single integer, containing the price of the most expensive tree connecting all the barns. If it is not possible to connect all the barns, output -1.

Sample Input

5 8
1 2 3
1 3 7
2 3 10
2 4 4
2 5 8
3 4 6
3 5 2
4 5 17

Sample Output

42

Hint

OUTPUT DETAILS: 

The most expensive tree has cost 17 + 8 + 10 + 7 = 42. It uses the following connections: 4 to 5, 2 to 5, 2 to 3, and 1 to 3.

Source



题目大意:n个顶点,m条边,每条边有一个cost。 从m条边中选择若干条边使得n个顶点构成一颗树,要求cost的总和花费最大

解析:如果是求最小cost,那么明显是最小生成树,而这道题比较特殊,求的是最大cost,看到这个题时,我也比较懵逼,就试着用prime算法写了一遍,然后改了下

            大于与小于号,就AC了,比赛过后,看了别人的博客,才知道这个叫做最大生成树,2333333


代码如下:

#include<iostream>
#include<algorithm>
#include<queue>
#include<map>
#include<vector>
#include<string>
#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<cctype>
#include<cmath>
#define N 1009
using namespace std;
const int inf = 0x3f3f3f3f;
const int mod = 10000007;
int mp[N][N], used[N], n, m;
int pri()
{
    int i, j, dis[N];
    for(i = 1; i <= n; i++)
        dis[i] = mp[1][i];
    dis[1] = 0;
    int ans = 0;
    used[1] = 1;
    for(i = 1; i <= n; i++)
    {
        int m, f = 0;
        for(j = 1; j <= n; j++)
        {
            if(!used[j] && f < dis[j])
                f = dis[m = j];
        }
        if(f == 0) break;
        used[m] = 1;
        ans += dis[m];
        for(j = 1; j <= n; j++)
            if(!used[j] && dis[j] < mp[m][j])
                dis[j] = mp[m][j];
    }
    for(i = 2; i <= n; i++)
    {
        if(dis[i] == 0)
            return -1;
    }
    return ans;

}
int main()
{
    while(~scanf("%d%d", &n, &m))
    {
        int u, v, w;
        memset(mp, 0, sizeof(mp));
        memset(used, 0, sizeof(used));
        for(int i = 1; i <= m; i++)
        {
            scanf("%d%d%d", &u, &v, &w);
            if(mp[u][v] < w)  mp[u][v] = mp[v][u] = w;
        }
        int ans = pri();
        cout << ans << endl;
    }
    return 0;
}




评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值