hdu 3549 Flow Problem (最大流—EK—Dinic)

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=3549


Flow Problem

Time Limit: 5000/5000 MS (Java/Others)    Memory Limit: 65535/32768 K (Java/Others)
Total Submission(s): 13526    Accepted Submission(s): 6465


Problem Description
Network flow is a well-known difficult problem for ACMers. Given a graph, your task is to find out the maximum flow for the weighted directed graph.
 

Input
The first line of input contains an integer T, denoting the number of test cases.
For each test case, the first line contains two integers N and M, denoting the number of vertexes and edges in the graph. (2 <= N <= 15, 0 <= M <= 1000)
Next M lines, each line contains three integers X, Y and C, there is an edge from X to Y and the capacity of it is C. (1 <= X, Y <= N, 1 <= C <= 1000)
 

Output
For each test cases, you should output the maximum flow from source 1 to sink N.
 

Sample Input
  
  
2 3 2 1 2 1 2 3 1 3 3 1 2 1 2 3 1 1 3 1
 

Sample Output
  
  
Case 1: 1 Case 2: 2
 

Author
HyperHexagon
 

Source
 

Recommend
zhengfeng   |   We have carefully selected several similar problems for you:   3572  3416  3081  3491  1533 
 



题目大意:给出u—>v的流量 c ,求1—>n的最大流量


解析:EK,或者 Dinic

Dinic:

#include<iostream>
#include<algorithm>
#include<map>
#include<stack>
#include<queue>
#include<set>
#include<string>
#include<cstdio>
#include<cstring>
#include<cctype>
#include<cmath>
#define N 19
using namespace std;
const int inf = 1e9;
const int mod = 1<<30;
const double eps = 1e-8;
const double pi = acos(-1.0);
typedef long long LL;
int n, mp[N][N], pre[N], book[N];
int bfs()
{
    memset(pre, 0, sizeof(pre));
    queue<int> q;
    q.push(1);
    pre[1] = 1;
    while(!q.empty())
    {
        int u = q.front(); q.pop();
        if(u == n) break;
        for(int i = 1; i <= n; i++)
        {
            if(!pre[i] && mp[u][i])
            {
                pre[i] = pre[u] + 1;
                q.push(i);
            }

        }
    }
    return pre[n] > 0;
}

int dfs(int u, int cur_flow)
{
    int i;
    if(u == n) return cur_flow;
    for(i = 1; i <= n; i++)
    {
        if(mp[u][i] > 0 && pre[u] + 1 == pre[i])
        {
            int f = dfs(i, min(cur_flow, mp[u][i]));
            if(f)
            {
                mp[u][i] -= f;
                mp[i][u] += f;
                return f;
            }
        }
    }
    return 0;
}
int Dinic()
{
    int f, ans = 0;
    while(bfs())
    {
        while((f = dfs(1, inf)))
            ans += f;
    }
    return ans;
}

int main()
{
    int m, u, v, w, i, t, cnt = 0;
    cin >> t;
    while(t--)
    {
        memset(mp, 0, sizeof(mp));
        scanf("%d%d", &n, &m);
        for(i = 1; i <= m; i++)
        {
            scanf("%d%d%d", &u, &v, &w);
            mp[u][v] += w;
        }
        int ans = Dinic();
        printf("Case %d: %d\n", ++cnt, ans);
    }
    return 0;
}

EK:


#include<iostream>
#include<algorithm>
#include<map>
#include<stack>
#include<queue>
#include<set>
#include<string>
#include<cstdio>
#include<cstring>
#include<cctype>
#include<cmath>
#define N 19
using namespace std;
const int inf = 1e9;
const int mod = 1<<30;
const double eps = 1e-8;
const double pi = acos(-1.0);
typedef long long LL;
int n, mp[N][N], pre[N], book[N];
int EK()
{
    int ans = 0;
    while(1)
    {
        memset(pre, 0, sizeof(pre));
        memset(book, 0,sizeof(book));
        queue<int> q;
        q.push(1);
        book[1] = 1;
        while(!q.empty())
        {
            int u = q.front();
            q.pop();
            for(int i = 1; i <= n; i++)
            {
                if(!book[i] && mp[u][i])
                {
                    book[i] = 1;
                    q.push(i);
                    pre[i] = u;
                }
            }
        }
        int m = inf;
        if(!book[n]) break;
        for(int i = n; i != 1; i = pre[i])
        {
            m = min(m, mp[pre[i]][i]);
        }
        for(int i = n; i != 1; i = pre[i])
        {
            mp[pre[i]][i] -= m;
            mp[i][pre[i]] += m;
        }
        ans += m;
    }
    return ans;
}

int main()
{
    int m, u, v, w, i, t, cnt = 0;
    cin >> t;
    while(t--)
    {
        memset(mp, 0, sizeof(mp));
        scanf("%d%d", &n, &m);
        for(i = 1; i <= m; i++)
        {
            scanf("%d%d%d", &u, &v, &w);
            mp[u][v] += w;
        }
        int ans = EK();
        printf("Case %d: %d\n", ++cnt, ans);
    }
    return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值