hdu 2612 Find a way(BFS + 最短路)

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=2612


Find a way

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 10934    Accepted Submission(s): 3585


Problem Description
Pass a year learning in Hangzhou, yifenfei arrival hometown Ningbo at finally. Leave Ningbo one year, yifenfei have many people to meet. Especially a good friend Merceki.
Yifenfei’s home is at the countryside, but Merceki’s home is in the center of city. So yifenfei made arrangements with Merceki to meet at a KFC. There are many KFC in Ningbo, they want to choose one that let the total time to it be most smallest. 
Now give you a Ningbo map, Both yifenfei and Merceki can move up, down ,left, right to the adjacent road by cost 11 minutes.
 

Input
The input contains multiple test cases.
Each test case include, first two integers n, m. (2<=n,m<=200). 
Next n lines, each line included m character.
‘Y’ express yifenfei initial position.
‘M’    express Merceki initial position.
‘#’ forbid road;
‘.’ Road.
‘@’ KCF
 

Output
For each test case output the minimum total time that both yifenfei and Merceki to arrival one of KFC.You may sure there is always have a KFC that can let them meet.
 

Sample Input
  
  
4 4 Y.#@ .... .#.. @..M 4 4 Y.#@ .... .#.. @#.M 5 5 Y..@. .#... .#... @..M. #...#
 

Sample Output
  
  
66 88 66
 

Author
yifenfei
 

Source
 

Recommend
yifenfei
 

Statistic |  Submit |  Discuss |  Note


题目大意: yifenfei 和 Merceki 想要见面,找一个最近的 KCF ,求他们总共需要走的最近距离,Y代表  yifenfei 的家, M 代表 Merceki 的家,

               @代表KFC,#代表墙,.代表能走的路


解析:开两个数组分别存这两个人到任意地点要走的路程,两边BFS,然后就下到@的最小值,输出即可


代码如下:


#include<iostream>
#include<algorithm>
#include<map>
#include<stack>
#include<queue>
#include<vector>
#include<set>
#include<string>
#include<cstdio>
#include<cstring>
#include<cctype>
#include<cmath>
#define N 209
using namespace std;
const int inf = 1e9;
const int mod = 1<<30;
const double eps = 1e-8;
const double pi = acos(-1.0);
typedef long long LL;
char mp[210][210];
int m, n, a[N][N], b[N][N];
int nx[11] = {-1, 0, 0, 1};
int ny[11] = {0, -1, 1, 0};
struct node
{
    int x, y;
};
void bfs(int s, int e)
{
    int i, x, y;
    a[s][e] = 0;
    queue<node> q;
    node now, nn;
    now.x = s; now.y = e;
    q.push(now);
    while(!q.empty())
    {
        now = q.front(); q.pop();
        for(i = 0; i < 4; i++)
        {
            x = now.x + nx[i]; y = now.y + ny[i];
            if(x < 1 || y < 1 || x > m || y > n) continue;
            if(a[x][y] != -1 || mp[x][y] == '#') continue;
            a[x][y] = a[now.x][now.y] + 1;
            nn.x = x; nn.y = y;
            q.push(nn);
        }
    }
}

void Bfs(int s, int e)
{
    int i, x, y;
    b[s][e] = 0;
    queue<node> q;
    node now, nn;
    now.x = s; now.y = e;
    q.push(now);
    while(!q.empty())
    {
        now = q.front(); q.pop();

        for(i = 0; i < 4; i++)
        {
            x = now.x + nx[i]; y = now.y + ny[i];
            if(x < 1 || y < 1 || x > m || y > n) continue;
            if(b[x][y] != -1 || mp[x][y] == '#') continue;
            b[x][y] = b[now.x][now.y] + 1;
            nn.x = x; nn.y = y;
            q.push(nn);
        }
    }
}


int main()
{
    int i, j, Y1, Y2, M1, M2;
    while(~scanf("%d%d", &m, &n))
    {
        for(i = 1; i <= m; i++)
        {
            for(j = 1; j <= n; j++)
            {
                scanf(" %c", &mp[i][j]);
                if(mp[i][j] == 'Y') Y1 = i, Y2 = j;
                else if(mp[i][j] == 'M') M1 = i, M2 = j;
            }
        }
        memset(a, -1 ,sizeof(a));
        memset(b, -1, sizeof(b));
        bfs(Y1, Y2);
        Bfs(M1, M2);
        int ans = inf;
        for(i = 1; i <= m; i++)
        {
            for(j = 1; j <= n; j++)
            {
                if(mp[i][j] == '@' && a[i][j] != -1 && b[i][j] != -1) ans = min(ans, a[i][j] + b[i][j]);//-1表示不能到达该KFC
            }
        }
        printf("%d\n", ans * 11);
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值