poj 3624 Charm Bracelet (0-1)

题目链接:http://poj.org/problem?id=3624


Charm Bracelet
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 34518 Accepted: 15294

Description

Bessie has gone to the mall's jewelry store and spies a charm bracelet. Of course, she'd like to fill it with the best charms possible from the N (1 ≤ N ≤ 3,402) available charms. Each charm i in the supplied list has a weight Wi (1 ≤ Wi ≤ 400), a 'desirability' factor Di (1 ≤ Di ≤ 100), and can be used at most once. Bessie can only support a charm bracelet whose weight is no more than M (1 ≤ M ≤ 12,880).

Given that weight limit as a constraint and a list of the charms with their weights and desirability rating, deduce the maximum possible sum of ratings.

Input

* Line 1: Two space-separated integers: N and M
* Lines 2..N+1: Line i+1 describes charm i with two space-separated integers: Wi and Di

Output

* Line 1: A single integer that is the greatest sum of charm desirabilities that can be achieved given the weight constraints

Sample Input

4 6
1 4
2 6
3 12
2 7

Sample Output

23

Source

[Submit]   [Go Back]   [Status]   [Discuss]




题目大意:Bessie 去珠宝店买手镯,他最后带重量为W的手镯,求最大魅力价值,下面给出每个重量及魅力价值

解析:0-1背包,套公式即可


代码如下:


#include<iostream>
#include<algorithm>
#include<map>
#include<stack>
#include<queue>
#include<vector>
#include<set>
#include<string>
#include<cstdio>
#include<cstring>
#include<cctype>
#include<cmath>
#define N 12889
using namespace std;
const int inf = 1e9;
const int mod = 1<<30;
const double eps = 1e-8;
const double pi = acos(-1.0);
typedef long long LL;

int dp[N], a[N], b[N];

int main()
{
    int v, n, i, j;

    scanf("%d%d", &n, &v);
    for(i = 1; i <= n; i++) scanf("%d%d", &b[i], &a[i]);

    memset(dp, 0, sizeof(dp));
    for(i = 1; i <= n; i++)
    {
        for(j = v; j >= b[i]; j--)
        {
            dp[j] = max(dp[j], dp[j - b[i]] + a[i]);
        }
    }
    printf("%d\n", dp[v]);

    return 0;
}







评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值