poj 2965 The Pilots Brothers' refrigerator(翻转)

题目链接:http://poj.org/problem?id=2965


The Pilots Brothers' refrigerator
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 25992 Accepted: 10024 Special Judge

Description

The game “The Pilots Brothers: following the stripy elephant” has a quest where a player needs to open a refrigerator.

There are 16 handles on the refrigerator door. Every handle can be in one of two states: open or closed. The refrigerator is open only when all handles are open. The handles are represented as a matrix 4х4. You can change the state of a handle in any location [i, j] (1 ≤ i, j ≤ 4). However, this also changes states of all handles in row i and all handles in column j.

The task is to determine the minimum number of handle switching necessary to open the refrigerator.

Input

The input contains four lines. Each of the four lines contains four characters describing the initial state of appropriate handles. A symbol “+” means that the handle is in closed state, whereas the symbol “−” means “open”. At least one of the handles is initially closed.

Output

The first line of the input contains N – the minimum number of switching. The rest N lines describe switching sequence. Each of the lines contains a row number and a column number of the matrix separated by one or more spaces. If there are several solutions, you may give any one of them.

Sample Input

-+--
----
----
-+--

Sample Output

6
1 1
1 3
1 4
4 1
4 3
4 4

Source

Northeastern Europe 2004, Western Subregion

[Submit]   [Go Back]   [Status]   [Discuss]

Home Page   Go Back  To top


题意:求所有加好变成减号翻转的最小次数,翻转当前位置,它所在的行和列都翻转

解析:就是再开个数组,把所有的加号翻转一下,所有位置翻转奇数次,那么这个位置就必须要翻转,最后输出路径就可以了


代码:

#include<iostream>
#include<algorithm>
#include<cstdio>
#include<cstring>
#include<vector>
#include<stack>
#include<queue>
#define N 9
using namespace std;
const int INF = 0x3f3f3f3f;

int mp[N][N], g[N][N];

int solve()
{
    memset(g, 0, sizeof(g));
    for(int i = 0; i < 4; i++)
    {
        for(int j = 0; j < 4; j++)
        {
            if(mp[i][j])
            {
                for(int k = 0; k < 4; k++)
                {
                    g[i][k] = !g[i][k];
                    g[k][j] = !g[k][j];
                }
                g[i][j] = !g[i][j];
            }
        }
    }
    int ans = 0;
    for(int i = 0; i < 4; i++)
    {
        for(int j = 0; j < 4; j++)
            if(g[i][j]) ans++;
    }
    return ans;
}


int main()
{
    char ch;
    memset(mp, 0, sizeof(mp));
    for(int i = 0; i < 4; i++)
    {
        for(int j = 0; j < 4; j++)
        {
            scanf(" %c", &ch);
            if(ch == '+') mp[i][j] = 1;
        }
    }

    printf("%d\n", solve());
    for(int i = 0; i < 4; i++)
    {
        for(int j = 0; j < 4; j++)
            if(g[i][j]) printf("%d %d\n", i + 1, j + 1);
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值