求素数

Problem A: 求素数

Time Limit: 1 Sec   Memory Limit: 128 MB
Submit: 280   Solved: 43
[ Submit][ Status][ Web Board]

Description

设计一个程序,输出所有小于等于n(n为一个大于2的正整数)的素数。输入包含多组测试数据。

要求:(1)每行输出10个素数。

            (2)尽量采用较优的算法。

Input

50

Output

      2     3     5     7    11     13     17   19   23   29

   31   37   41   43   47

Sample Input

50

Sample Output

    2    3    5    7   11   13   17   19   23   29
   31   37   41   43   47
#include<stdio.h>
#include<stdlib.h>
#include<string.h>
#include<math.h>
int main()
{
	int n,i,j,s=0,k;
	while(scanf("%d",&n)!=EOF)
	{
		for(i=2;i<=n;i++)
		{
			k=1;
			for(j=2;j<i;j++)
			{
				if(i%j==0)
				{
					k=0;
				}
			}
			if(k==1)
			{
				s++;
				printf("   %2d",i);
				if(s%10==0)	printf("\n");	
			}
		}
		s=0;
	}
	printf("\n");
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值