对称排序

题目地址:http://acm.nyist.net/JudgeOnline/problem.php?pid=283
对称排序
时间限制:1000 ms | 内存限制:65535 KB
难度:1
描述
In your job at Albatross Circus Management (yes, it’s run by a bunch of clowns), you have just finished writing a program whose output is a list of names in nondescending order by length (so that each name is at least as long as the one preceding it). However, your boss does not like the way the output looks, and instead wants the output to appear more symmetric, with the shorter strings at the top and bottom and the longer strings in the middle. His rule is that each pair of names belongs on opposite ends of the list, and the first name in the pair is always in the top part of the list. In the first example set below, Bo and Pat are the first pair, Jean and Kevin the second pair, etc.
输入
The input consists of one or more sets of strings, followed by a final line containing only the value 0. Each set starts with a line containing an integer, n, which is the number of strings in the set, followed by n strings, one per line, NOT SORTED. None of the strings contain spaces. There is at least one and no more than 15 strings per set. Each string is at most 25 characters long.
输出
For each input set print “SET n” on a line, where n starts at 1, followed by the output set as shown in the sample output.
If length of two strings is equal,arrange them as the original order.(HINT: StableSort recommanded)
样例输入
7
Bo
Pat
Jean
Kevin
Claude
William
Marybeth
6
Jim
Ben
Zoe
Joey
Frederick
Annabelle
5
John
Bill
Fran
Stan
Cece
0
样例输出
SET 1
Bo
Jean
Claude
Marybeth
William
Kevin
Pat
SET 2
Jim
Zoe
Frederick
Annabelle
Joey
Ben
SET 3
John
Fran
Cece
Stan
Bill
来源
POJ
上传者
sadsad

问题分析:
题目大意:输入一些字符串,当你写了对这些字符串排序的程序后,老板还要求再输出的时候对称输出,所谓对称输出即对于排序后的字符串,第一个放在前面,第二个放在后面,第三个再放在前面,第四个放在后面,以此类推。
程序要做的工作:
1.排序。即对输入的n个字符串进行排序。(n<=15) 每个字符串的长度m<=25.
2.对称输出。对排序后的字符串进行对称的输出。
输出顺序如下例子:
7
Bo 0
Jean 2
Claude 4
Marybeth 6
William 5
Kevin 3
Pat 1

6
Jim 0
Ben 2
Zoe 4
Joey 5
Frederick 3
Annabelle 1
代码:

#include <iostream>
#include <string.h>
#include <stdio.h>
#include <algorithm>
using namespace std;
/* run this program using the console pauser or add your own getch, system("pause") or input loop */
struct Word{
    char str[26];
    bool operator <(const Word &w)const{
        int length1 = strlen(str);
        int length2 = strlen(w.str);

        if(length1<length2){
            return true;
        }else{
            return false;
        }
    } 
}; 
bool comp(Word w1,Word w2){
    int length1= strlen(w1.str);
    int length2= strlen(w2.str);

    if(length1 < length2){
        return true;
    }else{
        return false;
    }
}

int main(int argc, char** argv) {

    int count = 1;
    int n;
    while(scanf("%d",&n)){
        if(n == 0){
            break;
        }

        //1.输入存储 
        Word w[16];

        for(int i=0;i<n;i++){
            scanf("%s",&w[i].str);
        }

        //2.排序 
        sort(w,w+n,comp);

        //3.输出
        printf("SET %d\n",count++);
            //先输出1,3,5,....n
        for(int i=0;i<n;i+=2)   {
            printf("%s\n",w[i].str);
        }
        //对偶数个数string做出调整以统一输出 
        if(n%2 == 1){

        }else{
            n++;  //输出方便 
        }

        for(int i=n-2;i>=1;i-=2) {
            printf("%s\n",w[i].str);
        }
    }

    return 0;
}
  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值