Frequent Subsets Problem

The frequent subset problem is defined as follows. Suppose UU={1, 2,\ldots,N} is the universe, and S_{1}S1S_{2}S2,\ldots,S_{M}SM are MM sets over UU. Given a positive constant \alphaα0<\alpha \leq 10<α1, a subset BB (B \neq 0B0) is α-frequent if it is contained in at least \alpha MαM sets of S_{1}S1S_{2}S2,\ldots,S_{M}SM, i.e. \left | \left \{ i:B\subseteq S_{i} \right \} \right | \geq \alpha M{i:BSi}αM. The frequent subset problem is to find all the subsets that are α-frequent. For example, let U=\{1, 2,3,4,5\}U={1,2,3,4,5}M=3M=3\alpha =0.5α=0.5, and S_{1}=\{1, 5\}S1={1,5}S_{2}=\{1,2,5\}S2={1,2,5}S_{3}=\{1,3,4\}S3={1,3,4}. Then there are 33 α-frequent subsets of UU, which are \{1\}{1},\{5\}{5} and \{1,5\}{1,5}.

Input Format

The first line contains two numbers NN and \alphaα, where NN is a positive integers, and \alphaα is a floating-point number between 0 and 1. Each of the subsequent lines contains a set which consists of a sequence of positive integers separated by blanks, i.e., line i + 1i+1 contains S_{i}Si1 \le i \le M1iM . Your program should be able to handle NN up to 2020and MM up to 5050.

Output Format

The number of \alphaα-frequent subsets.

样例输入
15 0.4
1 8 14 4 13 2
3 7 11 6
10 8 4 2
9 3 12 7 15 2
8 3 2 4 5
样例输出
11
题目来源

2017 ACM-ICPC 亚洲区(南宁赛区)网络赛

解题思路:题目中N的数目较小,直接暴力状态压缩。

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
using namespace std;
int n,m;
double p;
int num[100];

void read(char* str)
{
    if(strcmp(str,"\n")==0 || strcmp(str,"") == 0)
        return ;
    int i = 0;
    while(str[i] != '\0')
    {
        int t = 0;
        while(str[i] == ' ')
            i++;
        while(str[i] != ' '&&str[i] != '\0')
        {
            t = t*10 + str[i] - '0';
            i++;
        }
        num[m] += 1<<(t-1);
    }
    m++;
}

int main()
{
    scanf("%d %lf",&n,&p);
    m = 0;
    char str[1000];
    memset(num,0,sizeof(num));
    while(gets(str))
    {
        read(str);
    }
    int k = ceil(p*m);

    int ans = 0;
    for(int i = 1; i<(1<<n); i++)
    {
        int tmp = 0;
        for(int j = 0; j<m; j++)
        {
            if((num[j]&i) == i)
                tmp++;
        }
        if(tmp>=k)
            ans++;
    }
    printf("%d\n",ans);
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值