PAT - 甲级 - 1005. Spell It Right (20)

Given a non-negative integer N, your task is to compute the sum of all the digits of N, and output every digit of the sum in English.

Input Specification:

Each input file contains one test case. Each case occupies one line which contains an N (<= 10100).

Output Specification:

For each test case, output in one line the digits of the sum in English words. There must be one space between two consecutive words, but no extra space at the end of a line.

Sample Input:
12345
Sample Output:
one five

题目大概意思:第一行给出一个不大于10^100数,将各个位上的数组相加的和 用英文输出相加的和各个位置的数字,如12345,1+2+3+4+5=15  输出 one five;

10^100肯定不能用int   long long  定义一个字符数组保存  char num[101]即可;

输出的话,先用取余的方法将各个位数组存储到另一个数组中,然后逆序输出即可(因为取余是从低位取到高位);



#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
string print1[10] ={"zero","one","two","three","four","five","six","seven","eight","nine"}; 
int numPrint[101];
int main(){
	char num[101];
	scanf("%s",num);
	int len = strlen(num);
	int sum = 0;
	for(int i=0 ;i<len ;i++){
		sum += num[i]-'0';
	}

	if(sum==0){	//如果是0 直接输出zero 即可 
		printf("zero\n");
	}else{
		int n=0;
		while(sum>10){
			numPrint[n] = sum%10;
			sum /= 10;
			n++;
		}
		numPrint[n] = sum; //别忘了处理最后一位 
		
		for(int i=n ;i>=0 ;i--){

			if(i==n){
				cout<<print1[numPrint[i]];
			}else{
				cout<<" "<<print1[numPrint[i]];
			}
		}
		printf("\n");
	}
	
	
	
	return 0;
}




  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值