PAT - 甲级 - 1119. Pre- and Post-order Traversals (30) (递归建树)

Suppose that all the keys in a binary tree are distinct positive integers. A unique binary tree can be determined by a given pair of postorder and inorder traversal sequences, or preorder and inorder traversal sequences. However, if only the postorder and preorder traversal sequences are given, the corresponding tree may no longer be unique.

Now given a pair of postorder and preorder traversal sequences, you are supposed to output the corresponding inorder traversal sequence of the tree. If the tree is not unique, simply output any one of them.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<=30), the total number of nodes in the binary tree. The second line gives the preorder sequence and the third line gives the postorder sequence. All the numbers in a line are separated by a space.

Output Specification:

For each test case, first printf in a line "Yes" if the tree is unique, or "No" if not. Then print in the next line the inorder traversal sequence of the corresponding binary tree. If the solution is not unique, any answer would do. It is guaranteed that at least one solution exists. All the numbers in a line must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input 1:
7
1 2 3 4 6 7 5
2 6 7 4 5 3 1
Sample Output 1:
Yes
2 1 6 4 7 3 5
Sample Input 2:
4
1 2 3 4
2 4 3 1
Sample Output 2:
No
2 1 3 4

题目大意:给定先序和后序遍历,求中序遍历。并且输出中序遍历是否是唯一的。

思路: 求中序遍历:建树,通过递归建树

    求是否唯一:如果非叶子结点只有一个孩子节点,那么该树就不是唯一的。因为可以是左孩子也可以是右孩子。


#include<cstdio>
using namespace std;
int pr[31],po[31],in[31];
int len=0,n;  
int build(int l1,int r1,int l2,int r2){
	if(l1>r1)return 0;
	if(l1==r1){
		in[++len]=pr[l1];
		return 1;
	}
	
	int i=l2;
	while(pr[l1+1]!=po[i])i++;
	
	//递归建树 
	int ok = 1;
	ok &= build(l1+1,l1+1+i-l2,l2,i);
	in[++len] = pr[l1];
	ok &= build(l1+2+i-l2,r1,i+1,r2-1);
	return ok;	
}
  	
int main(){
	
	scanf("%d",&n);
	for(int i=1 ;i<=n ;i++)
		scanf("%d",&pr[i]);
	for(int i=1 ;i<=n ;i++)	
		scanf("%d",&po[i]);
	puts(build(1,n,1,n)?"Yes":"No");
	
	for(int i=1 ;i<=len ;i++)	
		printf("%d%c",in[i],i==len?'\n':' ');
	
	return 0;
} 




  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值