PAT - 甲级 - 1126. Eulerian Path (25)

题目描述:

In graph theory, an Eulerian path is a path in a graph which visits every edge exactly once. Similarly, an Eulerian circuit is an Eulerian path which starts and ends on the same vertex. They were first discussed by Leonhard Euler while solving the famous Seven Bridges of Konigsberg problem in 1736. It has been proven that connected graphs with all vertices of even degree have an Eulerian circuit, and such graphs are calledEulerian. If there are exactly two vertices of odd degree, all Eulerian paths start at one of them and end at the other. A graph that has an Eulerian path but not an Eulerian circuit is calledsemi-Eulerian. (Cited from https://en.wikipedia.org/wiki/Eulerian_path)

Given an undirected graph, you are supposed to tell if it is Eulerian, semi-Eulerian, or non-Eulerian.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 2 numbers N (<= 500), and M, which are the total number of vertices, and the number of edges, respectively. Then M lines follow, each describes an edge by giving the two ends of the edge (the vertices are numbered from 1 to N).

Output Specification:

For each test case, first print in a line the degrees of the vertices in ascending order of their indices. Then in the next line print your conclusion about the graph -- either "Eulerian", "Semi-Eulerian", or "Non-Eulerian". Note that all the numbers in the first line must be separated by exactly 1 space, and there must be no extra space at the beginning or the end of the line.

Sample Input 1:
7 12
5 7
1 2
1 3
2 3
2 4
3 4
5 2
7 6
6 3
4 5
6 4
5 6
Sample Output 1:
2 4 4 4 4 4 2
Eulerian
Sample Input 2:
6 10
1 2
1 3
2 3
2 4
3 4
5 2
6 3
4 5
6 4
5 6
Sample Output 2:
2 4 4 4 3 3
Semi-Eulerian
Sample Input 3:
5 8
1 2
2 5
5 4
4 1
1 3
3 2
3 4
5 3
Sample Output 3:
3 3 4 3 3
Non-Eulerian

题目思路:

题目给出n个结点的m条边。

题目要求:

1.输出每个结点的度(degree).

2.如果所有结点的度都是偶数(存在一条从某结点出发,经过所有的点和边且不重复,再回到起点的路线),输出"Eulerian".

3.如果有2个结点的读是奇数,其他的度都是偶数则输出"Semi-Eulerian",

4.除了情况2,3则输出"Non-Eulerian"

注意:2,3情况的前提条件是所有结点是连通的。

这里degree用一维数组记录,判断连通性使用了并查集。

题目代码:

#include <cstdio>
#include <cstring>
using namespace std;
int p[505];

int find(int x){
	return p[x] == x ? x : p[x] = find(p[x]);
}

int d[505];

int n, m, x, y;
int main(){
	scanf("%d%d",&n, &m);
	memset(d,0,sizeof(d));
	// 并查集初始化 
	for(int i = 1; i <= n; i++) p[i] = i;

	for(int i = 1; i <= m; i++){
		scanf("%d%d",&x, &y);
		d[x]++; d[y]++;
		
		int fx = find(x);
		int fy = find(y);
		if(fx != fy) p[fx] = fy;	
	}
	
	int oddNum = 0; // 奇数度结点数 
	int rootNum = 0; // 根节点个数 
	
	for(int i = 1; i <= n; i++){
		if(i!=1) printf(" ");
		printf("%d",d[i]);
		
		if(d[i]&1) oddNum ++;
		
		if(find(i) == i) rootNum ++;
	}
	puts("");
	
	if(!oddNum && rootNum == 1){
		puts("Eulerian");
	}
	else if(oddNum == 2 && rootNum == 1){
		puts("Semi-Eulerian");
	}else{
		puts("Non-Eulerian");
	}
	
	return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值