PAT - 甲级 - 1104. Sum of Number Segments (20)(逻辑题)

题目描述:

Given a sequence of positive numbers, a segment is defined to be a consecutive subsequence. For example, given the sequence {0.1, 0.2, 0.3, 0.4}, we have 10 segments: (0.1) (0.1, 0.2) (0.1, 0.2, 0.3) (0.1, 0.2, 0.3, 0.4) (0.2) (0.2, 0.3) (0.2, 0.3, 0.4) (0.3) (0.3, 0.4) (0.4).

Now given a sequence, you are supposed to find the sum of all the numbers in all the segments. For the previous example, the sum of all the 10 segments is 0.1 + 0.3 + 0.6 + 1.0 + 0.2 + 0.5 + 0.9 + 0.3 + 0.7 + 0.4 = 5.0.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N, the size of the sequence which is no more than 105. The next line contains N positive numbers in the sequence, each no more than 1.0, separated by a space.

Output Specification:

For each test case, print in one line the sum of all the numbers in all the segments, accurate up to 2 decimal places.

Sample Input:
4
0.1 0.2 0.3 0.4 
Sample Output:
5.00

题目思路:

刚看到题目首先想到dfs枚举子集求和,但是这些数字片段并不是所有的子集。然后想到各个数字的个数是否有一定的规律,


如图,我们发现1和4的个数,2和3的个数是一样的,而他们的位置对称,所以这个思路应该没错,给定一个数,这个数左边也可以放数字,右边也可以放数字,那么该数字出现的次数就应该是  左边的情况 * 右边的情况。

题目代码

#include <cstdio>
using namespace std;

double ans = 0;
double a[100000]; 
int n;

int main(){
	
	scanf("%d",&n);
	for(int i = 0; i < n; i++){
		scanf("%lf",&a[i]);
	}

	for(int i = 0; i < n; i++){
		ans += a[i] * (i+1) * (n-i);
	}
	printf("%.2f\n",ans);
	
	return 0;
} 


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值