PAT - 甲级 - 1084. Broken Keyboard (20)(Hash散列)

On a broken keyboard, some of the keys are worn out. So when you type some sentences, the characters corresponding to those keys will not appear on screen.

Now given a string that you are supposed to type, and the string that you actually type out, please list those keys which are for sure worn out.

Input Specification:

Each input file contains one test case. For each case, the 1st line contains the original string, and the 2nd line contains the typed-out string. Each string contains no more than 80 characters which are either English letters [A-Z] (case insensitive), digital numbers [0-9], or "_" (representing the space). It is guaranteed that both strings are non-empty.

Output Specification:

For each test case, print in one line the keys that are worn out, in the order of being detected. The English letters must be capitalized. Each worn out key must be printed once only. It is guaranteed that there is at least one worn out key.

Sample Input:
7_This_is_a_test
_hs_s_a_es
Sample Output:
7TI

给定条件:
1.两个字符串
2.第一个字符串是想要通过键盘打出的字符串
3.第二个字符串是实际通过键盘打出的字符串

要求:
1.求出键盘上的那些按键是坏了
2.输出要求
2.1.输出顺序是被发现的顺序
2.2.输出的英文字母要求是大写
2.3.输出的字符不出现重复

求解:
1.对能打出的字符进行标记,则期望打出的字符串中,没有被标记的就是坏了的键盘
2.对已判定为坏了的并且已输出的键进行标记,防止重复输出


#include<iostream>
#include<cstdio>
#include<string>
using namespace std;

string s1, s2;
bool isBroken[1000];
bool isPrinted[1000];

int main(){
	fill(isBroken, isBroken+1000, false);
	fill(isPrinted, isPrinted+1000, false);
	cin>>s1>>s2;
	for(int i = 0; i < s2.length(); i++) {
		if(s2[i] >= 'a' && s2[i] <= 'z') {
			isBroken[s2[i]] = isBroken[s2[i]-'a'+'A'] = true;
		} else if(s2[i] >= 'A' && s2[i] <= 'Z') {
			isBroken[s2[i]] = isBroken[s2[i]-'A'+'a'] = true;
		} else {
			isBroken[s2[i]] = true;
		}
	}
	
	for(int i = 0; i < s1.length(); i++) {
		if(isBroken[s1[i]] == false && isPrinted[s1[i]] == false) {
			if(s1[i] >= 'a' && s1[i] <= 'z'){
				isPrinted[s1[i]] = isPrinted[s1[i]-'a'+'A'] = true;
				printf("%c", s1[i]-'a'+'A');
			} else if(s1[i] >= 'A' && s1[i] <= 'Z') {
				isPrinted[s1[i]] = isPrinted[s1[i]-'A'+'a'] = true;
				printf("%c", s1[i]);
			} else {
				isPrinted[s1[i]] = true;
				printf("%c", s1[i]);
			}
			
		}
	}
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值