PAT - 甲级 - 1039. Course List for Student (25)(STL-vecotr)

Zhejiang University has 40000 students and provides 2500 courses. Now given the student name lists of all the courses, you are supposed to output the registered course list for each student who comes for a query.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers: N (<=40000), the number of students who look for their course lists, and K (<=2500), the total number of courses. Then the student name lists are given for the courses (numbered from 1 to K) in the following format: for each course i, first the course index i and the number of registered students Ni (<= 200) are given in a line. Then in the next line, Ni student names are given. A student name consists of 3 capital English letters plus a one-digit number. Finally the last line contains the N names of students who come for a query. All the names and numbers in a line are separated by a space.

Output Specification:

For each test case, print your results in N lines. Each line corresponds to one student, in the following format: first print the student's name, then the total number of registered courses of that student, and finally the indices of the courses in increasing order. The query results must be printed in the same order as input. All the data in a line must be separated by a space, with no extra space at the end of the line.

Sample Input:
11 5
4 7
BOB5 DON2 FRA8 JAY9 KAT3 LOR6 ZOE1
1 4
ANN0 BOB5 JAY9 LOR6
2 7
ANN0 BOB5 FRA8 JAY9 JOE4 KAT3 LOR6
3 1
BOB5
5 9
AMY7 ANN0 BOB5 DON2 FRA8 JAY9 KAT3 LOR6 ZOE1
ZOE1 ANN0 BOB5 JOE4 JAY9 FRA8 DON2 AMY7 KAT3 LOR6 NON9
Sample Output:
ZOE1 2 4 5
ANN0 3 1 2 5
BOB5 5 1 2 3 4 5
JOE4 1 2
JAY9 4 1 2 4 5
FRA8 3 2 4 5
DON2 2 4 5
AMY7 1 5
KAT3 3 2 4 5
LOR6 4 1 2 4 5
NON9 0

给定条件:
1.N个学生,K门课
2.每门课上的学生名单

要求:
1.输出每个学生上的课

求解:
1.用vector容器,存储每个学生的课程
2.遍历输出即可

注意:
这里使用string会导致最后一个测试点超时(知道为啥不?因为我试过了233)
因为每个学生的“名字”是A-Z的三个字母,然后加一个数字,我们可以把给定的名字看作是一个26进制的数,把它转换成10进制。
注意最后还以一个数字,直接补到最后一位。


#include <iostream>
#include <algorithm>
#include <cstdio>
#include <vector>
using namespace std;

const int maxn = 26 * 26 * 26 * 10 + 10;

vector<int> m[maxn];

int k, n, cid, num;
char name[5];

int getid(char *name) {
    int id = 0;
    for(int i = 0; i < 3; i++) {
        id = 26 * id + (name[i] - 'A');
    }
    // id += name[3] - '0';
    id = id * 10 + (name[3] - '0');
    return id;
}

int main(){
	scanf("%d%d", &n, &k);
	for(int i = 0; i < k; i++) {
		scanf("%d%d",&cid, &num);
		for(int j = 0; j < num; j++) {
			scanf("%s",name);
			int pid = getid(name);
			m[pid].push_back(cid);
		}
	}
	for(int i = 0; i < n; i++) {
		scanf("%s",name);
		printf("%s ",name);
		int pid = getid(name);
		int cnt = m[pid].size();
		printf("%d", cnt);
		sort(m[pid].begin(), m[pid].end());
		for(int j = 0; j < cnt; j++) {
			printf(" %d", m[pid][j]);
		}
		printf("\n");
	}
	return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值