PAT - 甲级 - 1012. The Best Rank (25)(排序)

To evaluate the performance of our first year CS majored students, we consider their grades of three courses only: C - C Programming Language, M - Mathematics (Calculus or Linear Algebra), and E - English. At the mean time, we encourage students by emphasizing on their best ranks -- that is, among the four ranks with respect to the three courses and the average grade, we print the best rank for each student.

For example, The grades of C, M, E and A - Average of 4 students are given as the following:

StudentID  C  M  E  A
310101     98 85 88 90
310102     70 95 88 84
310103     82 87 94 88
310104     91 91 91 91

Then the best ranks for all the students are No.1 since the 1st one has done the best in C Programming Language, while the 2nd one in Mathematics, the 3rd one in English, and the last one in average.

Input

Each input file contains one test case. Each case starts with a line containing 2 numbers N and M (<=2000), which are the total number of students, and the number of students who would check their ranks, respectively. Then N lines follow, each contains a student ID which is a string of 6 digits, followed by the three integer grades (in the range of [0, 100]) of that student in the order of C, M and E. Then there are M lines, each containing a student ID.

Output

For each of the M students, print in one line the best rank for him/her, and the symbol of the corresponding rank, separated by a space.

The priorities of the ranking methods are ordered as A > C > M > E. Hence if there are two or more ways for a student to obtain the same best rank, output the one with the highest priority.

If a student is not on the grading list, simply output "N/A".

Sample Input
5 6
310101 98 85 88
310102 70 95 88
310103 82 87 94
310104 91 91 91
310105 85 90 90
310101
310102
310103
310104
310105
999999
Sample Output
1 C
1 M
1 E
1 A
3 A
N/A


给定条件
1.n个学生的3门成绩

要求:
1.求出每个学生的平均成绩
2.求出每个学生的单门(包括平均成绩)排名最高的成绩(排名和课程名)
3.如果多门排名一样,按照一下优先级输出 A > C > M > E
4.输出最好成绩的排名情况和课程名

求解:
1.用结构体封装平均成绩、三门课程成绩,三门课程和平均成绩的排名情况,最好成绩的课程
2.平均成绩可以通过给定的三门成绩求出
3.三门课和平均成绩的排名情况,可以分别进行四次排序求得
4.每个人的最好成绩可以通过对比三门课和平均成绩的情况求的


#include <cstdio>
#include <algorithm>
using namespace std;

struct ST {
	int id;
	int score[4], rank[4];
	int best;
} st[2005];
int flag;
bool cmp(ST s1, ST s2) {
	return s1.score[flag] > s2.score[flag];
}
int exist[1000000];
int n, m;
int main() {
	freopen("input.txt", "r", stdin);
	fill(exist, exist+1000000, 0);

	scanf("%d%d", &n, &m);
	for(int i = 0; i < n; i++) {
		scanf("%d%d%d%d", &st[i].id, &st[i].score[1], &st[i].score[2], &st[i].score[3]);
		st[i].score[0] = (st[i].score[1] + st[i].score[2] + st[i].score[3]) / 3; 
	}

	for(flag = 0; flag <= 3; flag++) {
		sort(st, st+n, cmp);
		st[0].rank[flag] = 1;

		for(int j = 1; j < n; j++) {
			st[j].rank[flag] = j+1;
			if(st[j].score[flag] == st[j-1].score[flag]) {
				st[j].rank[flag] = st[j-1].rank[flag];
			}
		}
	}

	for(int i = 0; i < n; i++) {
		int id = st[i].id;
		exist[id] = i+1;
		st[i].best = 0;
		int minn = st[i].rank[0];
		for(int j = 1; j < 4; j++) {
			if(minn > st[i].rank[j]) {
				minn = st[i].rank[j];
				st[i].best = j;
			}
		}
	}

	int query;
	char c[4] = {'A', 'C', 'M', 'E'};
	for(int i = 0; i < m; i++) {
		scanf("%d", &query);

		int id = exist[query];
		if(id != 0) {
			id-=1;
			printf("%d %c\n", st[id].rank[st[id].best], c[st[id].best]);
		} else {
			printf("N/A\n");
		}
	}
	return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值