PAT - 甲级 - 1016. Phone Bills (25)(排序)

A long-distance telephone company charges its customers by the following rules:

Making a long-distance call costs a certain amount per minute, depending on the time of day when the call is made. When a customer starts connecting a long-distance call, the time will be recorded, and so will be the time when the customer hangs up the phone. Every calendar month, a bill is sent to the customer for each minute called (at a rate determined by the time of day). Your job is to prepare the bills for each month, given a set of phone call records.

Input Specification:

Each input file contains one test case. Each case has two parts: the rate structure, and the phone call records.

The rate structure consists of a line with 24 non-negative integers denoting the toll (cents/minute) from 00:00 - 01:00, the toll from 01:00 - 02:00, and so on for each hour in the day. 

The next line contains a positive number N (<= 1000), followed by N lines of records. Each phone call record consists of the name of the customer (string of up to 20 characters without space), the time and date (mm:dd:hh:mm), and the word "on-line" or "off-line".

For each test case, all dates will be within a single month. Each "on-line" record is paired with the chronologically next record for the same customer provided it is an "off-line" record. Any "on-line" records that are not paired with an "off-line" record are ignored, as are "off-line" records not paired with an "on-line" record. It is guaranteed that at least one call is well paired in the input. You may assume that no two records for the same customer have the same time. Times are recorded using a 24-hour clock.

Output Specification:

For each test case, you must print a phone bill for each customer. 

Bills must be printed in alphabetical order of customers' names. For each customer, first print in a line the name of the customer and the month of the bill in the format shown by the sample. Then for each time period of a call, print in one line the beginning and ending time and date (dd:hh:mm), the lasting time (in minute) and the charge of the call. The calls must be listed in chronological order. Finally, print the total charge for the month in the format shown by the sample.

Sample Input:
10 10 10 10 10 10 20 20 20 15 15 15 15 15 15 15 20 30 20 15 15 10 10 10
10
CYLL 01:01:06:01 on-line
CYLL 01:28:16:05 off-line
CYJJ 01:01:07:00 off-line
CYLL 01:01:08:03 off-line
CYJJ 01:01:05:59 on-line
aaa 01:01:01:03 on-line
aaa 01:02:00:01 on-line
CYLL 01:28:15:41 on-line
aaa 01:05:02:24 on-line
aaa 01:04:23:59 off-line
Sample Output:
CYJJ 01
01:05:59 01:07:00 61 $12.10
Total amount: $12.10
CYLL 01
01:06:01 01:08:03 122 $24.40
28:15:41 28:16:05 24 $3.85
Total amount: $28.25
aaa 01
02:00:01 04:23:59 4318 $638.80
Total amount: $638.80

给定条件:
1.一天中不同时间段通话的费用 单位是 (美分/分钟)
2.给定一些人的通话的开始时间和结束时间

要求:
1.每个人的每段通话的开始时间和结束时间,这段时间的总时长,以及这段时间的花费
2.每个人的一个月的通话总费用

注意:
1.给定的数据是乱序的
2.给定的数据中存在无效数据(比如某人的拨打了n次电话,接通了m次电话,那么就有abs(n-m)条无效数据)
3.每个人的通话记录可能有多条

求解:
1.将数据按照名字的字段序排列,名字相同时,按照时间先后顺序排
2.将同一个人的合法的数据存起来
3.遍历每个人的合法数据,做相应处理即可

计算:
计算某一时刻到另一时刻的费用时比较繁琐,可以先计算出从0时刻分别到两个时刻的花费,然后相减即可。


#include <iostream>
#include <cstdio>
#include <map>
#include <vector>
#include <algorithm>

using namespace std;

int rate[25];
int n;

struct Customer{
	string name;
	int month, day, hour, minute;
	int status; // 1:on-line 0:off-line
	int time; //

}cus[1010];

bool cmp(Customer cus1, Customer cus2) {
	return cus1.name != cus2.name ? cus1.name < cus2.name : cus1.time < cus2.time;
}

// 将时间转换成分钟
int tominute(Customer cus) { 
	return (cus.day * 24 * 60) + (cus.hour * 60) + (cus.minute);
}

// 计算从0天0点0分到现在花费
double getfeeform0(Customer cus) {
	double ans = 0;
	ans += rate[cus.hour] * cus.minute;
	ans += rate[24] * cus.day * 60;
	for(int i = 0; i < cus.hour; i++) {
		ans += rate[i] * 60;
	}
	return ans;
}

// 计算从mm:dd:hh:mm 某刻都某刻的费用
double getfee(Customer cus1, Customer cus2) {
	printf("%02d:%02d:%02d %02d:%02d:%02d %d ", cus1.day, cus1.hour, cus1.minute, cus2.day, cus2.hour, cus2.minute, cus2.time-cus1.time);
	return getfeeform0(cus2) - getfeeform0(cus1);
}



int main() {
	freopen("input.txt", "r", stdin);
	rate[24] = 0;
	for(int i = 0; i < 24; i++) {
		scanf("%d", &rate[i]);
		rate[24] += rate[i]; // 一天的rate
	}
	scanf("%d", &n);
	for(int i = 0; i < n; i++) {
		cin>>cus[i].name;
		scanf("%d:%d:%d:%d", &cus[i].month, &cus[i].day, &cus[i].hour, &cus[i].minute);
		string temp;
		cin>>temp;
		cus[i].status = temp == "on-line" ? 1 : 0;
		cus[i].time = 0;
		cus[i].time += tominute(cus[i]);
	}
	sort(cus, cus+n, cmp); 
	// 用来存储一个客户的多条通话
	map<string, vector<Customer> > talks;
	for(int i = 1; i < n; i++) {
		if(cus[i].name == cus[i-1].name && cus[i].status == 0 && cus[i-1].status == 1) {
			talks[cus[i].name].push_back(cus[i-1]);
			talks[cus[i].name].push_back(cus[i]);
		}
	}
	// 遍历输出
	map<string, vector<Customer> >::iterator it;
	for(it = talks.begin(); it != talks.end(); it++) {
		double totl = 0;
		cout<<it->first;
		vector<Customer> temp = it->second;
		printf(" %02d\n", temp[0].month);
		for(int i = 0; i < temp.size(); i+=2) {
			double subtol = getfee(temp[i],temp[i+1]);
			totl += subtol;
			printf("$%.2lf\n", subtol/100.0);
		}
		printf("Total amount: $%.2lf\n", totl/100.0);
	}
	
	return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值