PAT - 甲级 - 1061. Dating (20)(字符串处理)

Sherlock Holmes received a note with some strange strings: "Let's date! 3485djDkxh4hhGE 2984akDfkkkkggEdsb s&hgsfdk d&Hyscvnm". It took him only a minute to figure out that those strange strings are actually referring to the coded time "Thursday 14:04" -- since the first common capital English letter (case sensitive) shared by the first two strings is the 4th capital letter 'D', representing the 4th day in a week; the second common character is the 5th capital letter 'E', representing the 14th hour (hence the hours from 0 to 23 in a day are represented by the numbers from 0 to 9 and the capital letters from A to N, respectively); and the English letter shared by the last two strings is 's' at the 4th position, representing the 4th minute. Now given two pairs of strings, you are supposed to help Sherlock decode the dating time.

Input Specification:

Each input file contains one test case. Each case gives 4 non-empty strings of no more than 60 characters without white space in 4 lines.

Output Specification:

For each test case, print the decoded time in one line, in the format "DAY HH:MM", where "DAY" is a 3-character abbreviation for the days in a week -- that is, "MON" for Monday, "TUE" for Tuesday, "WED" for Wednesday, "THU" for Thursday, "FRI" for Friday, "SAT" for Saturday, and "SUN" for Sunday. It is guaranteed that the result is unique for each case.

Sample Input:
3485djDkxh4hhGE 
2984akDfkkkkggEdsb 
s&hgsfdk 
d&Hyscvnm
Sample Output:
THU 14:04

给定条件:
1.4个字符串
2.星期判断:前两个字符串第一个相同的'A'到'G'的大写字母
3.小时判断:前两个字符串第二个相同的'A'到'N'的大写字母或者'0'到'9'
4.分钟判断:后两个字符串第一个相同的字母的下标

要求:
1.按照格式输出日期

求解:
1.按照给定条件进行判断即可


#include <cstdio>
#include <map>
#include <cctype>
#include <iostream>
#include <cstring>
#define min(a,b) (a)>(b)?(b):(a)
using namespace std;

char str1[65], str2[65], str3[65], str4[65];
int day, hour, minute;
int j;
string daymap[7] = {"MON", "TUE", "WED", "THU", "FRI", "SAT", "SUN"};
int main() {
	scanf("%s%s%s%s", str1, str2, str3, str4);
	
	int min1 = min(strlen(str1), strlen(str2));
	int min2 = min(strlen(str1), strlen(str2));


	for(int i = 0; i < min1; i++) {
		if(str1[i] == str2[i] && str1[i] >= 'A' && str1[i] <= 'G') {
			day = str1[i] - 'A';
			j = i+1;
			break;
		}
	}
	for(int i = j; j < min1; i++) {
		if(str1[i] == str2[i] && ((str1[i] >= 'A' && str1[i] <= 'N') || isdigit(str1[i]))) {
			if(!isdigit(str1[i])) {
				hour = str1[i] - 'A' + 10;
			} else {
				hour = str1[i] - '0';
			}
			break;
		}
	}
	for(int i = 0; i < strlen(str3) && i < strlen(str4); i++) {
		if(str3[i] == str4[i] && isalpha(str3[i])) {
			minute = i;
			break;
		}
	}
	cout<<daymap[day];
	printf(" %02d:%02d\n", hour, minute);
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值